hdu 5800 To My Girlfriend (dp)

Problem Description
Dear Guo

I never forget the moment I met with you.You carefully asked me: "I have a very difficult problem. Can you teach me?".I replied with a smile, "of course"."I have n items, their weight was a[i]",you said,"Let's define f(i,j,k,l,m) to be the number of the subset of the weight of n items was m in total and has No.i and No.j items without No.k and No.l items.""And then," I asked.You said:"I want to know
i=1nj=1nk=1nl=1nm=1sf(i,j,k,l,m)(i,j,k,laredifferent)


Sincerely yours,
Liao
 

Input
The first line of input contains an integer T (T15)  indicating the number of test cases.
Each case contains 2 integers  n s   (4n1000,1s1000) . The next line contains n numbers:  a1,a2,,an   (1ai1000) .
 

Output
Each case print the only number — the number of her would modulo  109+7  (both Liao and Guo like the number).

 

Sample Input
  
  
2 4 4 1 2 3 4 4 4 1 2 3 4
 

Sample Output
  
  
8 8
 

思路:dp[i][t][k][j]; 0到i个数 和为j t个必取 k个必不取

解为 dp【n】【2】【2】【1~s】

#include <set>
#include <map>
#include <stack>
#include <queue>
#include <deque>
#include <cmath>
#include <vector>
#include <string>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
#define L(i) i<<1
#define R(i) i<<1|1
#define INF  0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-9
#define maxn 10010
#define MOD 1000000007

long long ans;
int T;

const int mod = 1e9 +7;
int n,s;

int a[1010];

int dp[1010][3][3][1010];


int main()
{
    scanf("%d",&T);

    while(T--)
    {
        scanf("%d%d",&n,&s);

        for(int i=1; i<=n; i++) scanf("%d",&a[i]);

        memset(dp,0,sizeof(dp));

        dp[0][0][0][0]=1;
        ans=0;

        for(int i=1; i<=n; i++)
        {
            for(int j=0; j<=s; j++)
            {
                for(int t=0; t<=2; t++)
                    for(int k=0; k<=2; k++)
                    {
                        dp[i][t][k][j] = dp[i-1][t][k][j];

                        if(j>=a[i])
                        {
                            dp[i][t][k][j] = (dp[i][t][k][j] + dp[i-1][t][k][j-a[i]]) % mod;

                            //choose
                            if(t>0)
                                dp[i][t][k][j] = (dp[i][t][k][j] + dp[i-1][t-1][k][j-a[i]]) %mod;
                        }

                        // no choose
                        if(k>0)
                            dp[i][t][k][j]  = (dp[i][t][k][j] + dp[i-1][t][k-1][j]) %mod;
                        }
            }
        }


//        for(int i=1; i<=n; i++)
//        {
//            for(int j=0; j<=s; j++)
//                for(int t=0; t<=2; t++)
//                    for(int k=0; k<=2; k++)
//                    {
//                        printf("dp[%d][%d][%d][%d] = %d\n",i,t,k,j,dp[i][t][k][j]);
//                    }
//        }

        for(int i=0; i<=s; i++)
            ans =(ans + dp[n][2][2][i])%mod;

        printf("%I64d\n",ans*4 %mod);
    }
    return 0;
}



 



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值