Ubuntu 14.04下安装eclipse遇到的兼容性问题

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_23096723/article/details/80553353

    我早先利用Ubuntu Software Center已经安装了eclipse,然而之后没怎么用;今天由于要开发web项目,所以打开eclipse打算新建web应用,结果发现菜单栏NEW中没有web选项,显然我现在的eclipse版本不完全或者没有安装好开发web项目的指定版本,于是我在网上寻找解决方法。

解决方法1:

在(eclipse安装目录下)eclipse.ini中直接把 -XX:+UseStringDeduplication 注释掉。

然而我按上面操作完之后,直接点击下面eclipse图标启动eclipse时


出现类似下面的报错:


该报错的大意是该eclipse版本仅支持>=jdk1.8 而我的jdk是1.7显然不兼容,此方法卒。

解决方法2:

到jdk官方网站上下载更高版本的JDK。

由于我之前的jdk 1.8跟那个啥~记不清了~不兼容所以我才换的jdk1.7,如果让我我再换回去,然后再折腾我的项目中其它软件环境的兼容性那是不可能的,此方法卒。

解决方法3:(我自己想的一个方法,那就下载支持jdk1.7能开发web应用的Eclipse IDE for Java EE Developers版本呗)

参考百度经验 https://jingyan.baidu.com/article/6766299784bb8154d51b84b6.html 找到下载旧版eclipse的入口;

先尝试了最新版本,也就是图片最下面的版本


结果只支持jdk 1.8, 此版本卒。

又尝试了下面的版本


不多说,卒;我想那就选个低点的版本吧。


此版本支持jdk 1.7,成功


展开阅读全文

没有更多推荐了,返回首页