HUNAN OJ 11567 Escaping

Problem description
One day, Large cruise ”Wu Kong” at sea. The station is represented by a square n*n divided into 1*1 blocks. Unfortunately , ” Wu Kong” hit an iceberg .It will sink after t minutes ,then every people die. However, there will be some life-saving equipment in some rooms(not only one), People from one room to reach another adjacent room (only four) needs one minute .If the people on board to get these life-saving devices so that they will survive, find the greatest number of people can survive.

Input
The first line contains two integers n and t (2 ≤ n ≤ 10, 1 ≤ t ≤ 10). Each of the next n lines contains n integers(0<=A[i][j]<=9).the people number at this time. Each of the next n more lines contains n integers, Indicates that the room have the number of life-saving equipment(0<=B[i][j]<=9).

Output
Print a single number — the maximum number of people who will be saved.

Sample Input
3 3
1 0 0
1 0 0
1 0 0
0 0 0
0 0 0
0 0 3

Sample Output
2

BFS预处理,然后建图跑最大流

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <vector>
#include <algorithm>
#include <queue>
#include <set>
#include <bitset>
#include <climits>

using namespace std;

const int INF = 0x3f3f3f3f;

const int MAXN = 200000;

const int MAXM = 400005;

int n, m, u, v, w;

struct point
{
    int x, y, step;
    friend bool operator < (const point& a, const point& b)
    {
        return a.step > b.step;
    }
};

int mp[15][15], a, t, x[15][15];

int dirx[] = {1, -1, 0, 0};

int diry[] = {0, 0, 1, -1};

bool vis[15][15];

struct Edge
{
    int to, next, flow;
} edge[MAXM];

int head[MAXN], tot;

void add(int u, int v, int w)
{
    edge[tot].to = v;
    edge[tot].flow = w;
    edge[tot].next = head[u];
    head[u] = tot++;

    edge[tot].to = u;
    edge[tot].flow = 0;
    edge[tot].next = head[v];
    head[v] = tot++;
}

int dep[MAXN];

bool bfs(int s, int t)
{
    int u;
    memset(dep, -1, sizeof(dep));
    queue <int> q;
    q.push(s);
    dep[s] = 0;
    while(!q.empty())
    {
        u = q.front();
        q.pop();
        for(int i = head[u]; ~i; i = edge[i].next)
        {
            int v = edge[i].to;
            if(dep[v] == -1 && edge[i].flow > 0)
            {
                dep[v] = dep[u] + 1;
                if(v == t)return true;
                q.push(v);
            }
        }
    }
    return false;
}

int dfs(int s, int t, int x)
{
    if(s == t)return x;
    int ans = x;
    for(int i = head[s]; ~i; i = edge[i].next)
    {
        int v = edge[i].to;
        if(dep[v] == dep[s] + 1 && edge[i].flow > 0)
        {
            int minn = dfs(v, t, min(x, edge[i].flow));
            edge[i].flow -= minn;
            edge[i ^ 1].flow += minn;
            x -= minn;
        }
    }
    return ans - x;
}

int dinic()
{
    int ans = 0;
    while(bfs(1, n))ans += dfs(1, n, INF);
    return ans;
}

bool judge(int x, int y)
{
    return (x >= 0 && x < a && y >= 0 && y < a && !vis[x][y]);
}

void pre(point x)
{
    priority_queue <point> q;
    point F, N;
    q.push(x);
    int node = x.x * a + x.y + 2;
    memset(vis, false, sizeof(vis));
    while(!q.empty())
    {
        F = q.top();
        q.pop();
        if(F.step > t)break;
        //cout<<mp[2][2]<<endl;
        if(mp[F.x][F.y] >= 1)add(node, F.x * a + F.y + a * a + 2, INF);
        for(int i = 0; i < 4; ++i)
        {
            N.x = F.x + dirx[i];
            N.y = F.y + diry[i];
            if(judge(N.x, N.y))
            {
                vis[N.x][N.y] = true;
                N.step = F.step + 1;
                q.push(N);
            }
        }
    }
}

point Q;

int main()
{
    //freopen("in.txt", "r", stdin);
    while(scanf("%d%d", &a, &t) == 2)
    {
        tot = 0;
        memset(head, -1, sizeof(head));
        for(int i = 0; i < a; ++i)
        {
            for(int j = 0; j < a; ++j)scanf("%d", &x[i][j]);
        }
        n = 2 * a * a + 2;
        for(int i = 0; i < a; ++i)
        {
            for(int j = 0; j < a; ++j)
            {
                scanf("%d", &mp[i][j]);
                if(mp[i][j] >= 1)add(a * a + 2 + i * a + j, n, mp[i][j]);
            }
        }
        for(int i = 0; i < a; ++i)
        {
            for(int j = 0; j < a; ++j)
            {
                if(x[i][j] >= 1)
                {
                    add(1, i * a + j + 2, x[i][j]);
                    Q.step = 0;
                    Q.x = i;
                    Q.y = j;
                    pre(Q);
                }
            }
        }
        printf("%d\n", dinic());
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
在信号处理领域,DOA(Direction of Arrival)估计是一项关键技术,主要用于确定多个信号源到达接收阵列的方向。本文将详细探讨三种ESPRIT(Estimation of Signal Parameters via Rotational Invariance Techniques)算法在DOA估计中的实现,以及它们在MATLAB环境中的具体应用。 ESPRIT算法是由Paul Kailath等人于1986年提出的,其核心思想是利用阵列数据的旋转不变性来估计信号源的角度。这种算法相比传统的 MUSIC(Multiple Signal Classification)算法具有较低的计算复杂度,且无需进行特征值分解,因此在实际应用中颇具优势。 1. 普通ESPRIT算法 普通ESPRIT算法分为两个主要步骤:构造等效旋转不变系统和估计角度。通过空间平移(如延时)构建两个子阵列,使得它们之间的关系具有旋转不变性。然后,通过对子阵列数据进行最小二乘拟合,可以得到信号源的角频率估计,进一步转换为DOA估计。 2. 常规ESPRIT算法实现 在描述中提到的`common_esprit_method1.m`和`common_esprit_method2.m`是两种不同的普通ESPRIT算法实现。它们可能在实现细节上略有差异,比如选择子阵列的方式、参数估计的策略等。MATLAB代码通常会包含预处理步骤(如数据归一化)、子阵列构造、旋转不变性矩阵的建立、最小二乘估计等部分。通过运行这两个文件,可以比较它们在估计精度和计算效率上的异同。 3. TLS_ESPRIT算法 TLS(Total Least Squares)ESPRIT是对普通ESPRIT的优化,它考虑了数据噪声的影响,提高了估计的稳健性。在TLS_ESPRIT算法中,不假设数据噪声是高斯白噪声,而是采用总最小二乘准则来拟合数据。这使得算法在噪声环境下表现更优。`TLS_esprit.m`文件应该包含了TLS_ESPRIT算法的完整实现,包括TLS估计的步骤和旋转不变性矩阵的改进处理。 在实际应用中,选择合适的ESPRIT变体取决于系统条件,例如噪声水平、信号质量以及计算资源。通过MATLAB实现,研究者和工程师可以方便地比较不同算法的效果,并根据需要进行调整和优化。同时,这些代码也为教学和学习DOA估计提供了一个直观的平台,有助于深入理解ESPRIT算法的工作原理。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值