从Alphacode看斐波那契数列与线性动态规划

Alice and Bob need to send secret messages to each other and are discussing ways to encode their messages: Alice: "Let's just use a very simple code: We'll assign `A' the code word 1, `B' will be 2, and so on down to `Z' being assigned 26." Bob: "That's a stupid code, Alice. Suppose I send you the word `BEAN' encoded as 25114. You could decode that in many different ways!" Alice: "Sure you could, but what words would you get? Other than `BEAN', you'd get `BEAAD', `YAAD', `YAN', `YKD' and `BEKD'. I think you would be able to figure out the correct decoding. And why would you send me the word `BEAN' anyway?" Bob: "OK, maybe that's a bad example, but I bet you that if you got a string of length 500 there would be tons of different decodings and with that many you would find at least two different ones that would make sense." Alice: "How many different decodings?" Bob: "Jillions!" For some reason, Alice is still unconvinced by Bob's argument, so she requires a program that will determine how many decodings there can be for a given string using her code.

Input

Input will consist of multiple input sets. Each set will consist of a single line of digits representing a valid encryption (for example, no line will begin with a 0). There will be no spaces between the digits. An input line of `0' will terminate the input and should not be processed

Output

For each input set, output the number of possible decodings for the input string. All answers will be within the range of a long variable.

Sample Input

25114
1111111111
3333333333
0

Sample Output

6

89

1

在写这道题之前,我是不知道什么叫线性动态规划的。

第一眼看上去,我就觉得很难,好像无从下手,那么就从最简单的开始吧,那就是1,有一种解释方法,然后是11,有两种解释方法,然后是111,有三种解释方法。

     1  一种情况

    11  两种情况

   111  三种情况

  1111  五种情况

于是,灵感来了,如果我们将上一级作为一个整体的时候就是这个情况

      1

  (1)1

 (11)1

(111)1

假如这个每一行新加的数不和第二个数组合,那么这一行这个情况等于上一行的情况数  即An=An-1

那么如果新加的数和前一个数组合,即

      1

   (11)

  1(11)

 11(11)

那么很容易看出 此时 An=An-2

所以综上所述,每一行的情况数An=An-1+An-2;

这不就是大名鼎鼎的斐波那契数列吗!!!!

 

然后考虑有两种特殊情况

case1:a+b>26

case2:a+b==10||a+b==20

 

这个很简单,我们可以一个一个数字扫描,当出现情形1;

那么这个数和上一个数就不能组合

此时 An=An-1;

当出现了0,那么它和上一个数必须组合

此时 An=An-2;

下面贴出代码

#include<iostream>
#include<string>
using namespace std;
int chartonum(char &a)
{
    a = (int)a - 48;
    return a;
}
int main()
{
    string mima;
    cin >> mima;
    for (int i = 1; i<1000; i++)

    while (mima != "0")
    {

        int a[100000] = { 1, 1 };
        int i;

        for (i = 1; i<mima.length(); i++)
        {
            char a1 = mima[i - 1], a2 = mima[i];
            if ((chartonum(a1) * 10 + chartonum(a2))>26||mima[i-1]=='0')
            {
                a[i + 1] = a[i]; continue;
            }
            if (mima[i] == '0')
            {
                a[i + 1] = a[i - 1]; continue;
            }
           
            a[i+1]= a[i] + a[i - 1];
            }
       
        cout << a[i] << endl;
        cin >> mima;
    }
    return 0;
}

看到这里,是不是觉得和01背包问题相似,一个数字问题竟能转化为01背包问题,斐波那契数列与线性动态规划竟有如此关系

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值