实验记录CCNP ROUTE HOMEWORK1 EIGRP

实验拓扑:
在这里插入图片描述
实验需求:

  1. 根据实验拓扑图,完成设备接口IP地址的配置
    解法:
    R1的配置:
    R1#configure terminal
    R1(config)#interface e1/0
    R1(config-if)#ip address 192.168.123.1 255.255.255.0
    R1(config-if)#no shutdown
    R2的配置:
    R2(config)#interface e1/0
    R2(config-if)#ip address 192.168.123.2 255.255.255.0
    R2(config-if)#no shutdown
    R2(config)#interface s2/0
    R2(config-if)#ip address 24.1.1.2 255.255.255.0
    R2(config-if)#no shutdown
    R2(config-if)#int e1/1
    R2(config-if)#ip address 25.1.1.2 255.255.255.0
    R2(config-if)#no shutdown
    R3的配置:
    R3(config)#interface e1/0
    R3(config-if)#ip address 192.168.123.3 255.255.255.0
    R3(config-if)#no shutdown
    R3(config)#interface s2/0
    R3(config-if)#ip address 35.1.1.3 255.255.255.0
    R3(config-if)#no shutdown
    R4的配置:
    R4(config)#interface s2/0
    R4(config-if)#ip address 24.1.1.4 255.255.255.0
    R4(config-if)#no shutdown
    R5的配置:
    R5(config)#interface e1/1
    R5(config-if)#ip address 25.1.1.5 255.255.255.0
    R5(config-if)#no shutdown
    R5(config)#interface s2/0
    R5(config-if)#ip address 35.1.1.5 255.255.255.0
    R5(config-if)#no shutdown
    R6的配置:
    R6(config)#interface e1/0
    R6(config-if)#ip address 192.168.56.6 255.255.255.0
    R6(config-if)#no shutdown

  2. 每台设备都有一个Loopback0接口,地址为X.X.X.X/32,X为设备编号,例如R1的Loopback0=1.1.1.1/32…,Loopback0接口需要宣告进EIGRP(R5的Lo0宣告进EIGRP 12345)
    解法:
    R1的配置:
    R1(config)#interface lo0
    R1(config-if)#ip address 1.1.1.1 255.255.255.255
    R1(config-if)#no shutdown
    R1(config)#router eigrp 12345
    R1(config-router)#network 1.1.1.1 255.255.255.255
    R2的配置:
    R2(config)#interface lo0
    R2(config-if)#ip address 2.2.2.2 255.255.255.255
    R2(config-if)#no shutdown
    R2(config)#router eigrp 12345
    R2(config-router)#network 2.2.2.2 255.255.255.255
    R3的配置:
    R3(config)#interface lo0
    R3(config-if)#ip address 3.3.3.3 255.255.255.255
    R3(config-if)#no shutdown
    R3(config)#router eigrp 12345
    R3(config-router)#network 3.3.3.3 255.255.255.255
    R4的配置:
    R4(config)#interface lo0
    R4(config-if)#ip address 4.4.4.4 255.255.255.255
    R4(config-if)#no shutdown
    R4(config)#router eigrp 12345
    R4(config-router)#network 4.4.4.4 255.255.255.255
    R5的配置:
    R5(config)#interface lo0
    R5(config-if)#ip address 5.5.5.5 255.255.255.255
    R5(config-if)#no shutdown
    R5(config)#router eigrp 12345
    R5(config-router)#network 5.5.5.5 255.255.255.255
    R6的配置:
    R6(config)#interface lo0
    R6(config-if)#ip address 6.6.6.6 255.255.255.255
    R6(config-if)#no shutdown
    R6(config)#router eigrp 56
    R6(config-router)#network 6.6.6.6 255.255.255.255

  3. 在R1上创建三个环回口Loopback1,Loopback2,Loopback3,IP地址分别为172.16.1.1/24,172.16.2.1/24,172.16.3.1/24
    解法:
    R1(config)#interface lo1
    R1(config-if)#ip address 172.16.1.1 255.255.255.0
    R1(config-if)#no shutdown
    R1(config)#interface lo2
    R1(config-if)#ip address 172.16.2.1 255.255.255.0
    R1(config-if)#no shutdown
    R1(config)#interface lo3
    R1(config-if)#ip address 172.16.3.1 255.255.255.0
    R1(config-if)#no shutdown

  4. 根据实验拓扑图,完成EIGRP 12345和EIGRP 56的基本配置,要求关闭自动汇总功能,EIGRP的宣告要求精确到接口
    解法:
    R1的配置:
    R1(config)#router eigrp 12345
    R1(config-router)#network 192.168.123.0 255.255.255.0
    R1(config-router)#no auto-summary
    R2的配置:
    R2(config)#router eigrp 12345
    R2(config-router)#network 192.168.123.0 255.255.255.0
    R2(config-router)#network 24.1.1.0 255.255.255.0
    R2(config-router)#network 25.1.1.0 255.255.255.0
    R2(config-router)#no auto-summary
    R3的配置:
    R3(config)#router eigrp 12345
    R3(config-router)#network 192.168.123.0 255.255.255.0
    R3(config-router)#network 35.1.1.0 255.255.255.0
    R3(config-router)#no auto-summary
    R4的配置:
    R4(config)#router eigrp 12345
    R4(config-router)#network 24.1.1.0 255.255.255.0
    R4(config-router)#no auto-summary
    R5的配置:
    R5(config)#router eigrp 12345
    R5(config-router)#network 35.1.1.0 255.255.255.0
    R5(config-router)#network 25.1.1.0 255.255.255.0
    R5(config-router)#no auto-summary
    R5(config)#router eigrp 56
    R5(config-router)#network 192.168.56.0 255.255.255.0
    R5(config-router)#no auto-summary
    R6的配置:
    R6(config)#router eigrp 56
    R6(config-router)#network 192.168.56.0 255.255.255.0
    R6(config-router)#no auto-summary

  5. 要求R1和R2之间,R1和R3之间使用单播建邻居,R2和R3之间不能建立EIGRP邻居关系
    解法:
    R1的配置:
    R1(config)#router eigrp 12345
    R1(config-router)#neighbor 192.168.123.2 e1/0
    R1(config-router)#neighbor 192.168.123.3 e1/0
    R2的配置:
    R2(config)#router eigrp 12345
    R2(config-router)#neighbor 192.168.123.1 e1/0
    R3的配置:
    R3(config)#router eigrp 12345
    R3(config-router)#neighbor 192.168.123.1 e1/0

  6. 要求R3和R5之间链路的Hello时间间隔为10秒,Hold-time时间为30秒
    解法:
    R3的配置:
    R3(config)#interface s2/0
    R3(config-if)#ip hello-interval eigrp 12345 10
    R3(config-if)#ip hold-time eigrp 12345 30
    R5的配置:
    R5(config)#interface s2/0
    R5(config-if)#ip hello-interval eigrp 12345 10
    R5(config-if)#ip hold-time eigrp 12345 30

  7. 要求R1不能往Lo1,Lo2,Lo3这三个接口发送Hello报文
    解法:
    R1(config)#router eigrp 12345
    R1(config-router)#passive-interface lo1
    R1(config-router)#passive-interface lo2
    R1(config-router)#passive-interface lo3

  8. 要求R1对Lo1,Lo2,Lo3这三个接口的路由进行手工汇总,汇总路由的掩码要尽可能精确
    解法:
    R1(config)#interface e1/0
    R1(config-if)#ip summary-address eigrp 12345 172.16.0.0 255.255.252.0

  9. 要求R5去往R1的汇总路由实现不等价负载均衡
    解法:
    R5的配置:
    interface Serial2/0
    bandwidth 1000000
    delay 10
    interface Ethernet1/1
    ip address 25.1.1.5 255.255.255.0
    delay 99
    R5(config)#router eigrp 12345
    R5(config-router)#variance 2
    R3的配置:
    interface Ethernet1/0
    ip address 192.168.123.3 255.255.255.0
    delay 190

  10. 要求R5分别向R2,R3下发一条默认路由
    解法:
    R5(config)#ip route 0.0.0.0 0.0.0.0 lo0
    R5(config)#router eigrp 12345
    R5(config-router)#redistribute static

  11. 要求在R2和R4之间启用EIGRP的MD5验证,密码为:XMWS
    解法:
    R2的配置:
    R2(config)#key chain R2
    R2(config-keychain)#key 1
    R2(config-keychain-key)#KEY-string XMWS
    R2(config)#interface s2/0
    R2(config-if)#ip authentication mode eigrp 12345 md5
    R2(config-if)#ip authentication key-chain eigrp 12345 R2
    R4的配置:
    R4(config)#key chain R4
    R4(config-keychain)#key 1
    R4(config-keychain-key)#key-string XMWS
    R2(config)#interface s2/0
    R4(config-if)#ip authentication mode eigrp 12345 md5
    R4(config-if)#ip authentication key-chain eigrp 12345 R4

  12. 要求R4不接收任何EIGRP的查询消息,R4只能发送直连路由信息给它的EIGRP邻居
    解法:
    R4(config)#router eigrp 12345
    R4(config-router)#eigrp stub connected

  13. 要求使用1条静态路由实现全网互通
    解法:
    R5(config)#router eigrp 56
    R5(config-router)#redistribute static

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值