POJ-2386(深广搜基础)

Lake Counting
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 25322 Accepted: 12759

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

思路:
很基础的一道题目,适合拿来练手,dfs和bfs都可以
一开始还理解错题目意思了,以为只有至少两个点连着的W才算是pool,结果发现并不是,说白了这题就是让你求图中并查集的个数
理论上应该也可以用并查集做吧,然后分别写出dfs和bfs的解法,需要注意的地方都加以注释了

dfs:
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;

int n,m;
char G[107][107];
int vis[107][107];
int dir[8][2] = {{-1,-1},{-1,0},{-1,1},{0,-1},{0,1},{1,-1},{1,0},{1,1}};

void dfs(int x,int y)
{
    for(int i = 0;i < 8;i++)
    {
        int dx = x+dir[i][0];
        int dy = y+dir[i][1];
        if(dx>=1&&dx<=n&&dy>=1&&dy<=m && G[dx][dy]=='W' && !vis[dx][dy]) {
            vis[dx][dy] = 1;
            dfs(dx,dy);
        }
    }
}

int main()
{
    while(cin>>n>>m)
    {
        memset(vis,0,sizeof(vis));
        int ans = 0;
        for(int i = 1;i <= n;i++)
            scanf("%s",&G[i][1]);//注意如果是从1开始计数,就要从每一行的第一位开始从缓冲区中读取数据,这个语法要注意一下,容易出错

        for(int i = 1;i <= n;i++)
            for(int j = 1;j <= m;j++)
                if(G[i][j]=='W' && !vis[i][j]) {//此处的!vis如果放到dfs函数的开头,则会比较难处理,if的效果就起不到了
                    vis[i][j] = 1;
                    dfs(i,j);
                    ans++;
                }
        cout<<ans<<endl;
    }
    return 0;
}
bfs:
#include <iostream>
#include <cstdio>
#include <queue>
using namespace std;

int n,m;
char G[107][107];
int dir[8][2] = {{-1,-1},{-1,0},{-1,1},{0,-1},{0,1},{1,-1},{1,0},{1,1}};
typedef pair<int,int> node;

void bfs(int x,int y)
{
    G[x][y] ='.';//比较好的一种处理方法,省去开vis数组
    priority_queue<node> q;//q中存储了(x,y)点的所有连通点 
    q.push(make_pair(x,y));
    while(!q.empty())
    {
        node t = q.top();
        q.pop();
        int tx = t.first;
        int ty = t.second; 
        for(int i = 0;i < 8;i++)
        {
            int dx = tx+dir[i][0];
            int dy = ty+dir[i][1];
            if(dx>=1&&dx<=n&&dy>=1&&dy<=m && G[dx][dy]=='W') {
                G[dx][dy] = '.';
                q.push(make_pair(dx,dy));
            }
        }
    }
}

int main()
{
    while(cin>>n>>m)
    {
        int ans = 0;
        for(int i = 1;i <= n;i++)
            scanf("%s",&G[i][1]);

        for(int i = 1;i <= n;i++)
            for(int j = 1;j <= m;j++) 
                if(G[i][j]=='W') {
                    bfs(i,j);
                    ans++;
                }
        cout<<ans<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值