HDU-1520 Anniversary party

Problem Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.
 

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0
 

Output

Output should contain the maximal sum of guests' ratings.
 
Sample Input
7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0
 
Sample Output
5

思路:
树形DP的入门题目,俩月之前做过一次,不过当时感觉不是太明白,这次做基本就给搞懂了
做这个题渐渐的有种感觉就是自己运用数据结构的能力有所增强,即每次要想实现什么东西感觉都不会太困难,或许是因为有了STL吧= =
好吧,说正经的
不知道怎么感觉DP和基础的递归越来越像,不过DP尤其是树形DP的关键似乎就在于找到父子结点之间的递推关系,即把原来的线性那一套玩儿法给挪到了树上,更奇妙
对于某个结点来说,它能返回的最大值就是选他和不选他二者之间最大的那一个,然后我们要做的只是分别求出这两个值再取最大的
随着时间的增加,越来越发现算导上说的那句话非常正确————DP的核心就是有重叠子问题

#include <iostream>
#include <cstdio>
#include <vector>
#define MAX 6007
#define max(a,b) (a)>(b)?(a):(b)
using namespace std;

vector<int> son[MAX];
int f[MAX];
int dp[MAX][2];
int d_max[MAX];
int c[MAX];

int df(int x)
{
	if(d_max[x] != -207)
		return d_max[x];
	else 
	{
		int len = son[x].size();
		for(int i = 0;i < len;i++) {
			int s = son[x][i];
			dp[x][0] += df(s);
			dp[x][1] += dp[s][0];
		}
		dp[x][1] += c[x]; 
		return d_max[x] = max(dp[x][0],dp[x][1]);
	}
}

int main()
{
	int n;
	while(cin>>n) {
		for(int i = 1;i <= n;i++) {
			cin>>c[i];
			//循环数据的初始化 
			d_max[i] = -207;
			f[i] = -1;
			dp[i][0] = dp[i][1] = 0;
			son[i].clear();
		}
		int t1,t2;
		while(scanf("%d%d",&t1,&t2) && t1 + t2) {
			son[t2].push_back(t1);
			f[t1] = t2;
		}
		//寻找树根 
		int head;
		for(int i = 1;i <= n;i++)
			if(f[i] == -1) {
				head = i;
				break;
			}
		//初始化叶子节点
		for(int i = 1;i <= n;i++) 
			if(son[i].empty()) 
				d_max[i] = dp[i][1] = c[i];
		//输出最终的答案 
		cout<<df(head)<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值