UVA 10038 - Jolly Jumpers

Description:
A sequence of n > 0 integers is called a jolly jumper if the absolute values of the difference between successive elements take on all the values 1 through n − 1. For instance,

1 4 2 3

is a jolly jumper, because the absolutes differences are 3, 2, and 1 respectively. The definition implies that any sequence of a single integer is a jolly jumper. You are to write a program to determine whether or not each of a number of sequences is a jolly jumper.

Input

Each line of input contains an integer n ≤ 3000 followed by n integers representing the sequence.

Output

For each line of input, generate a line of output saying ‘Jolly’ or ‘Not jolly’.

Sample Input

4 1 4 2 3
5 1 4 2 -1 6

Sample Output

Jolly
Not jolly

题意:给定一个整数n,有一个长度为n的整数序列,如果这个序列相邻两个整数之间的差的绝对值均在1到n-1之间,并且这之间的每个数字都只出现一次,那么这个序列叫做Jolly Jumpers。

思路:首先把这n个数字存到数组或者栈中,每次两两比较这两个数,用一个数组记录出现的所有数字的次数;这个题目最重要的一步就是判断1到n-1出现的数字,如果两数字的绝对值差出现的次数大于一次或者其差不在1到n-1之间,那么可以判断不满足题意,否则,符合题意。

注意:需要注意的是,题目并没有告诉我们序列中数字的大小,所以使用int类型会出现runtime error的错误,需要使用long类型。

#include <cstdio>
#include <stack>
#include <memory.h>
#include <cstdlib>

using namespace std;

int main()
{
    int cnt[3005];
    int n;
    while(~scanf("%d", &n)){
        long a, b, k;
        bool isJolly = true;
        stack<long> num;
        memset(cnt, 0, sizeof(int)*n);
        k = n;
        while(k--){
            long x;
            scanf("%ld", &x);
            num.push(x);
        }
        for(int i = 1; i < n; i++){
            a = num.top();
            num.pop();
            b = num.top();
            long diff = labs(a-b);
            cnt[diff]++;
            if(cnt[diff] > 1 || diff < 1 || diff > n-1){
                isJolly = false;
                break;
            }
        }
        if(isJolly)
            printf("Jolly\n");
        else
            printf("Not jolly\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值