hdu 5055 Bob and math problem

Bob and math problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1147    Accepted Submission(s): 430


Problem Description
Recently, Bob has been thinking about a math problem.
There are N Digits, each digit is between 0 and 9. You need to use this N Digits to constitute an Integer.
This Integer needs to satisfy the following conditions:
  • 1. must be an odd Integer.
  • 2. there is no leading zero.
  • 3. find the biggest one which is satisfied 1, 2.

Example:
There are three Digits: 0, 1, 3. It can constitute six number of Integers. Only "301", "103" is legal, while "130", "310", "013", "031" is illegal. The biggest one of odd Integer is "301".
 

Input
There are multiple test cases. Please process till EOF.
Each case starts with a line containing an integer N ( 1 <= N <= 100 ).
The second line contains N Digits which indicate the digit a1,a2,a3,,an.(0ai9) .
 

Output
The output of each test case of a line. If you can constitute an Integer which is satisfied above conditions, please output the biggest one. Otherwise, output "-1" instead.
 

Sample Input
  
  
3 0 1 3 3 5 4 2 3 2 4 6
 

Sample Output
  
  
301 425 -1
 

Source
 题目大意: 求取给出数字组成的最大的奇数
题目分析:计数排序,找最小的奇数,然后从大到小将值顺次填充,特判一下只有一个奇数,剩下的全是0的情况就能过
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>

using namespace std;

int n;
int num[11];
int a;

int main ( )
{
    while ( ~scanf ( "%d" , &n ) )
    {
      memset ( num , 0 , sizeof ( num ) );
      int end = -1;
      for ( int i = 0 ; i < n ; i++ )
      {
          scanf ( "%d" , &a );
          num[a]++;
      }
      for ( int i = 0 ; i <= 9 ; i++ )
        if ( (i&1)&& num[i] )
        {
            num[i]--;
            end = i;
            break;
        }
      if ( num[0] )
      {
          bool flag = true;
          for ( int i = 1 ; i <= 9 ; i++ )
              if ( num[i] ) flag = false;
          if ( flag ) end = -1;
      }
      if ( end == -1 ) 
      {
          puts ( "-1" );
          continue;
      }
      for ( int i = 9 ; i >= 0 ; i-- )
        while ( num[i] )
        {
            printf ( "%d" , i );
            num[i]--;
        }
      printf ( "%d\n" , end );
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值