hdu 5187 zhx's contest ( 数学+java)

zhx's contest

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 286    Accepted Submission(s): 102


Problem Description
As one of the most powerful brushes, zhx is required to give his juniors n problems.
zhx thinks the ith problem's difficulty is i . He wants to arrange these problems in a beautiful way.
zhx defines a sequence {ai} beautiful if there is an i that matches two rules below:
1: a1..ai are monotone decreasing or monotone increasing.
2: ai..an are monotone decreasing or monotone increasing.
He wants you to tell him that how many permutations of problems are there if the sequence of the problems' difficulty is beautiful.
zhx knows that the answer may be very huge, and you only need to tell him the answer module p .
 

Input
Multiply test cases(less than 1000 ). Seek EOF as the end of the file.
For each case, there are two integers n and p separated by a space in a line. ( 1n,p1018 )
 

Output
For each test case, output a single line indicating the answer.
 

Sample Input
  
  
2 233 3 5
 

Sample Output
  
  
2 1
Hint
In the first case, both sequence {1, 2} and {2, 1} are legal. In the second case, sequence {1, 2, 3}, {1, 3, 2}, {2, 1, 3}, {2, 3, 1}, {3, 1, 2}, {3, 2, 1} are legal, so the answer is 6 mod 5 = 1
 题目大意:求取符合条件数列的个数
题目解析:组合数学题,枚举最大的位置,可以得到C(n-1,0) +........C(n-1,n-1) ,符合二项公式,枚举最小项位置时同理,然后当最大项在两侧,和最小项在两侧重复了两次,减去
懒得写C++大数了,用java过得,C++大数取模就是利用好同余模定理就好了,水题1A
import java.math.BigInteger;
import java.util.Scanner;


public class Main
{
	 public static BigInteger pow ( BigInteger  n  , BigInteger p )
	  {
		  if ( n.equals( BigInteger.ZERO) ) return BigInteger.ONE;
		  BigInteger temp = pow ( n.divide(BigInteger.valueOf(2) ) , p );
		  if ( n.mod(BigInteger.valueOf(2) ).equals(BigInteger.ZERO ) )
			  return temp.multiply( temp ).mod(p);
		  else return temp.multiply(temp).multiply(BigInteger.valueOf(2) ).mod(p);
	  }
	
		public static void main (  String[] args )
		{
				BigInteger n,p;
				Scanner cin = new Scanner (System.in );
				while ( cin.hasNext() )
				{
						n = cin.nextBigInteger ( );
						p = cin.nextBigInteger ( );
						BigInteger ans = pow(n,p) .subtract(BigInteger.valueOf(2)).add(p).mod(p);
						System.out.println ( ans );
				}
		}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值