hdu 3341Lost's revenge(ac自动机+dp)

Lost's revenge

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 3165    Accepted Submission(s): 838


Problem Description
Lost and AekdyCoin are friends. They always play "number game"(A boring game based on number theory) together. We all know that AekdyCoin is the man called "nuclear weapon of FZU,descendant of Jingrun", because of his talent in the field of number theory. So Lost had never won the game. He was so ashamed and angry, but he didn't know how to improve his level of number theory.

One noon, when Lost was lying on the bed, the Spring Brother poster on the wall(Lost is a believer of Spring Brother) said hello to him! Spring Brother said, "I'm Spring Brother, and I saw AekdyCoin shames you again and again. I can't bear my believers were being bullied. Now, I give you a chance to rearrange your gene sequences to defeat AekdyCoin!".

It's soooo crazy and unbelievable to rearrange the gene sequences, but Lost has no choice. He knows some genes called "number theory gene" will affect one "level of number theory". And two of the same kind of gene in different position in the gene sequences will affect two "level of number theory", even though they overlap each other. There is nothing but revenge in his mind. So he needs you help to calculate the most "level of number theory" after rearrangement.
 

Input
There are less than 30 testcases.
For each testcase, first line is number of "number theory gene" N(1<=N<=50). N=0 denotes the end of the input file.
Next N lines means the "number theory gene", and the length of every "number theory gene" is no more than 10.
The last line is Lost's gene sequences, its length is also less or equal 40.
All genes and gene sequences are only contains capital letter ACGT.
 

Output
For each testcase, output the case number(start with 1) and the most "level of number theory" with format like the sample output.
 

Sample Input
  
  
3 AC CG GT CGAT 1 AA AAA 0
 

Sample Output
  
  
Case 1: 3 Case 2: 2
 

Author
Qinz@XDU
题目大意:给定一个基因串,又给出一些模式串,要将原串在不增删基因的情况下,如何改造才能得到最多的匹配数
题目分析:先利用模式串构造ac自动机,然后再自动机上dp,首先想到记录状态,也就是当前各个字母分别使用了的个数,还得开一维表示自动机的状态,一定会超内存,那么我们可以利用hash进行离散化后进行状态压缩,然后dp即可,转移比较简单,就是类似于树形dp地在字典树上转移,处理上要先将当前点记录下fail指针所指节点的匹配数,否则可能会超时.......
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
#define N 57
#define kind 4

using namespace std;

char st[N];
int n;
int Next[507][kind] , cnt[507] , fail[507] , pos;
int Hash[42][42][42][42];
int dp[11*11*11*11][507];

int index ( char ch )
{
    if ( ch == 'A' ) return 0;
    if ( ch == 'C' ) return 1;
    if ( ch == 'G' ) return 2;
    if ( ch == 'T' ) return 3;
}

int newNode ( )
{
    for ( int i = 0 ; i < kind ; i++ )
        Next[pos][i] = 0;
    fail[pos] = cnt[pos] = 0;
    return pos++;
}

void insert ( char *s )
{
    int i , p = 0;
    for ( i = 0 ; s[i] ; i++ )
    {
        int k = index ( s[i] ) , &x = Next[p][k];
        p = x?x:x = newNode ( );
    }
    cnt[p]++;
}

void build ( )
{
    int i;
    queue<int> q;
    q.push ( 0 );
    while ( !q.empty() )
    {
        int u = q.front();
        cnt[u] += cnt[fail[u]];
        q.pop ( );
        for ( int i = 0 ; i < kind ; i++ )
        {
            int v = Next[u][i];
            if ( v == 0 ) Next[u][i] = Next[fail[u]][i];
            else q.push ( v );
            if ( u && v )
                fail[v] = Next[fail[u]][i];
        }
    }
}

int sum[kind];

void compress ( char *s )
{
    int i = 0 ;
    int num = 0;
    memset ( sum , 0 , sizeof ( sum ) );
    memset ( Hash  , 0 , sizeof ( Hash ) );
    while ( s[i] ) sum[index(s[i++])]++;
    for ( int i = 0 ; i <= sum[0] ; i++ )
        for ( int j = 0 ; j <= sum[1] ; j++ )
            for ( int k = 0 ; k <= sum[2] ; k++ )
               for ( int t = 0 ; t <= sum[3] ; t++ )
                  Hash[i][j][k][t] = num++;
}

int ans;

void solve ( )
{
    memset ( dp , -1 , sizeof ( dp ) );
    dp[0][0] = 0;
    for ( int i = 0 ; i <= sum[0] ; i++ )
        for ( int j = 0 ; j <= sum[1] ; j++ )
            for ( int k = 0 ; k <= sum[2] ; k++ )
                for ( int t = 0 ; t <= sum[3] ;t++ )
                {
                    if ( i + j + k + t == 0 ) continue;
                    int x1 = Hash[i][j][k][t];
                    for ( int l = 0 ; l < pos ; l++ )
                        for ( int q = 0 ; q < kind ; q++ )
                        {
                            int x2;
                            if ( q == 0 && i - 1 >= 0 )
                                x2 = Hash[i-1][j][k][t];
                            else if ( q == 1 && j - 1 >= 0 )
                                x2 = Hash[i][j-1][k][t];
                            else if ( q == 2 && k - 1 >= 0 )
                                x2 = Hash[i][j][k-1][t];
                            else if ( q == 3 && t - 1 >= 0 )
                                x2 = Hash[i][j][k][t-1];
                            else continue;
                            int p = Next[l][q];
                            if ( dp[x2][l] == -1 ) continue;
                            dp[x1][p] = max ( dp[x1][p] , dp[x2][l] + cnt[p] );
                            ans = max ( ans , dp[x1][p] );
                        }
                }
}

int main ( )
{
    int c = 1;
    while ( ~scanf ( "%d" , &n ) , n )
    {
        ans = 0;
        pos = 0, newNode();
        for ( int i = 1 ; i <= n ; i++ )
        {
            scanf ( "%s" , st );
            insert ( st );
        }
        build ( );
        scanf ( "%s" , st );
        compress ( st  );
        solve ( );
        printf ( "Case %d: %d\n" , c++ , ans );
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值