hdu 3732 Ahui Writes Word(简单dp+贪心)

Ahui Writes Word

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2226    Accepted Submission(s): 816


Problem Description
We all know that English is very important, so Ahui strive for this in order to learn more English words. To know that word has its value and complexity of writing (the length of each word does not exceed 10 by only lowercase letters), Ahui wrote the complexity of the total is less than or equal to C.
Question: the maximum value Ahui can get.
Note: input words will not be the same.
 

Input
The first line of each test case are two integer N , C, representing the number of Ahui’s words and the total complexity of written words. (1 ≤ N ≤ 100000, 1 ≤ C ≤ 10000)
Each of the next N line are a string and two integer, representing the word, the value(Vi ) and the complexity(Ci ). (0 ≤ Vi , Ci ≤ 10)
 

Output
Output the maximum value in a single line for each test case.
 

Sample Input
  
  
5 20 go 5 8 think 3 7 big 7 4 read 2 6 write 3 5
 

Sample Output
  
  
15
Hint
Input data is huge,please use “scanf(“%s”,s)”
 

Author
Ahui
 题目分析:这道题直接背包一定超时,但是因为物品的体积比较小,所以我们可以将大部分利用贪心做,对物品按单位价值排序,然后逐个选取,当剩余容量较小时,因为可能出现物品太大,塞不进去导致错误,所以可以剩下一小部分进行背包即可
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAX 100007

using namespace std;

char s[20];
int dp[10007];
int n,m;

struct Point
{
    int v,c;
    bool operator < ( const Point&a ) const
    {
        return v*1.0/c > a.v*1.0/a.c;
    }
}p[MAX];

int main ( )
{
    while ( ~scanf ( "%d%d" , &n , &m ) )
    {
        int sum1 = 0 , sum2 = 0;
        for ( int i = 0 ; i < n ; i++ )
        {
            scanf ( "%s" , s );
            scanf ( "%d%d" , &p[i].v , &p[i].c );
            sum1 += p[i].v;
            sum2 += p[i].c;
        }
        if ( sum2 <= m )
        {
            printf ( "%d\n" , sum1 );
            continue;
        }
        sort ( p , p+n );
        int cur = 0 , sum3 = 0;
        while ( m > 30 )
        {
            sum3 += p[cur].v;
            m -= p[cur++].c;
        }
        memset ( dp , 0 , sizeof ( dp ) );
        for ( int i = cur ; i < n ; i++ )
            for ( int j = m ; j >= p[i].c ; j-- )
                dp[j] = max ( dp[j] , dp[j-p[i].c]+p[i].v );
        int ans = 0;
        for ( int i = 0 ; i <= m ; i++ )
            ans = max ( dp[i] , ans );
        printf ( "%d\n" , ans + sum3 );
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值