hdu 1233 还是畅通工程(最小生成树prim)

还是畅通工程

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 29137    Accepted Submission(s): 13031


Problem Description
某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。
 

Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
当N为0时,输入结束,该用例不被处理。
 

Output
对每个测试用例,在1行里输出最小的公路总长度。
 

Sample Input
  
  
3 1 2 1 1 3 2 2 3 4 4 1 2 1 1 3 4 1 4 1 2 3 3 2 4 2 3 4 5 0
 

Sample Output
  
  
3 5
Hint
Hint
Huge input, scanf is recommended.
 

Source
题目分析:
最小生成树,模板题,邻接链表构图
 
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <iostream>
#define MAX 107

using namespace std;

int n,m;

struct Edge
{
    int v,next,w;
}e[MAX*MAX<<1];

int head[MAX];
int cc;

void add ( int u , int v , int w )
{
    e[cc].v = v;
    e[cc].w = w;
    e[cc].next = head[u];
    head[u] = cc++;
}

bool used[MAX];
int cost[MAX];

int prim ()
{
    int ret = 0 , minn , u=1 ,pos;
    memset ( used , 0 , sizeof ( used ));
    memset ( cost , 0x3f , sizeof ( cost ));
    for ( int i = 1 ; i < n ; i++ )
    {
        used[u] = true;
        minn = cost[0];
        for ( int i = head[u] ; ~i ; i = e[i].next )
        {
            int v = e[i].v;
            if ( used[v] ) continue;
            cost[v] = min ( cost[v] , e[i].w );
            if ( cost[v] < minn )
                pos = v , minn = cost[v];
        }
        ret += minn;
        u = pos;
    }
    return ret;
}

int main ()
{
    int u,v,w;
    while ( ~scanf ( "%d" , &n ),n )
    {
        m = n*(n-1)/2;
        memset ( head , -1 , sizeof ( head ));
        cc = 0;
        for ( int i = 0 ; i < m ; i++ )
        {
            scanf ( "%d%d%d" , &u , &v , &w );
            add ( u , v , w );
            add ( v , u , w );
        }
        printf ( "%d\n" , prim ());
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值