hdu 1879 继续畅通工程最小生成树prim)

继续畅通工程

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15995    Accepted Submission(s): 6856


Problem Description
省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。现得到城镇道路统计表,表中列出了任意两城镇间修建道路的费用,以及该道路是否已经修通的状态。现请你编写程序,计算出全省畅通需要的最低成本。
 

Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( 1< N < 100 );随后的 N(N-1)/2 行对应村庄间道路的成本及修建状态,每行给4个正整数,分别是两个村庄的编号(从1编号到N),此两村庄间道路的成本,以及修建状态:1表示已建,0表示未建。

当N为0时输入结束。
 

Output
每个测试用例的输出占一行,输出全省畅通需要的最低成本。
 

Sample Input
  
  
3 1 2 1 0 1 3 2 0 2 3 4 0 3 1 2 1 0 1 3 2 0 2 3 4 1 3 1 2 1 0 1 3 2 1 2 3 4 1 0
 

Sample Output
  
  
3 1 0
 

Author
ZJU
 

Source
题目分析:
最小生成树prim模板题
 
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#define MAX 107

using namespace std;

int n,m,a,b,c,d;

struct Edge
{
    int v,w,next;
}e[MAX*MAX];

bool used[MAX];
int cost[MAX];
int head[MAX];
int cc;

void add ( int u , int v , int w )
{
    e[cc].v = v;
    e[cc].w = w;
    e[cc].next = head[u];
    head[u] = cc++;
}

int prim ( )
{
    memset ( used , false , sizeof (used ) );
    memset ( cost , 0x3f , sizeof ( cost ) );
    int u = 1 , minn ,ret = 0;
    for ( int i = 1 ; i < n ; i++ )
    {
        used[u] = true;
        minn = cost[0];
        for ( int j = head[u] ; ~j ; j = e[j].next )
        {
            int v = e[j].v;
            if ( used[v] ) continue;
            cost[v] = min ( cost[v] , e[j].w );
            if ( cost[v] < minn )
                minn = cost[v] , u = v;
        }
        ret += minn;
    }
    return ret;
}

int main ( )
{
    while ( ~scanf ( "%d" , &n ),n )
    {
        cc = 0;
        memset ( head , -1 , sizeof ( head ) );
        m = n*(n-1)/2;
        for ( int i = 0 ; i < m ; i++ )
        {
            scanf ( "%d%d%d%d" , &a , &b , &c , &d );
            if ( d ) c = 0;
            add ( a , b , c );
            add ( b , a , c );
        }
        printf ( "%d\n" , prim ( ) );
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值