ZOJ 1241 Geometry Made Simple

Geometry Made Simple

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 105   Accepted Submission(s) : 16
Problem Description
Mathematics can be so easy when you have a computer. Consider the following example. You probably know that in a right-angled triangle, the length of the three sides a, b, c (where c is the longest side, called the hypotenuse) satisfy the relation a*a+b*b=c*c. This is called Pythagora's Law.

Here we consider the problem of computing the length of the third side, if two are given.

Input

The input contains the descriptions of several triangles. Each description consists of a line containing three integers a, b and c, giving the lengths of the respective sides of a right-angled triangle. Exactly one of the three numbers is equal to -1 (the 'unknown' side), the others are positive (the 'given' sides).

A description having a=b=c=0 terminates the input.


Output

For each triangle description in the input, first output the number of the triangle, as shown in the sample output. Then print "Impossible." if there is no right-angled triangle, that has the 'given' side lengths. Otherwise output the length of the 'unknown' side in the format "s = l", where s is the name of the unknown side (a, b or c), and l is its length. l must be printed exact to three digits to the right of the decimal point.

Print a blank line after each test case.


Sample Input

3 4 -1
-1 2 7
5 -1 3
0 0 0


Sample Output

Triangle #1
c = 5.000

Triangle #2
a = 6.708

Triangle #3
Impossible.

 
 
注意:
1:此题考察sqrt 的使用 sqrt  输入时为double型或者int型(系统会自动转成double)      输出的值为double型
       double与int 混用出错的问题(出现好多次错误,均为此导致啊啊啊啊)
2:注意格式
3:输入保证只有一个为负数
       题目有漏洞 比如 输入 -1 -1 2 也能进行计算 提交竟然能AC
       为了考虑周到 加上if的判断条件
 
 
 
#include<stdio.h>
#include<math.h>
int main (void)
{
    int a,b,c;
    int d=1;
    while(~scanf("%d%d%d",&a,&b,&c),a||b||c)
    {
        double aa,bb,cc;
        if(a==-1)
        {
            aa=c*c-b*b;//int 与double 混用情况,不正确但也能过,最好不要使用这种方法
            printf("Triangle #%d\n",d);
            d++;
            if(aa<=0||b<=0||c<=0)//判断条件
            {
                 printf("Impossible.\n\n");
            }
            else
            printf("a = %.3lf\n\n",sqrt(aa));
            continue;
        }
        if(b==-1)
        {
            b=c*c-a*a;//正确的方法
            printf("Triangle #%d\n",d);
            d++;
            bb=sqrt(b);
            if(b<=0||a<=0||c<=0)//不要判断a和c也可AC(漏洞)
            {
                printf("Impossible.\n\n");
            }
            else
                printf("b = %.3lf\n\n",bb);
            continue;
        }
        if(c==-1)
        {
            cc=a*a+b*b;
            printf("Triangle #%d\n",d);
            d++;
            printf("c = %.3lf\n\n",sqrt(cc));
            continue;
        }
    }
    return 0;
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值