HDU 1005 Number Sequence【循环节】

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 148284    Accepted Submission(s): 36044

Problem Description
A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
Output
For each test case, print the value of f(n) on a single line.
Sample Input
  
  
1 1 3 1 2 10 0 0 0
Sample Output
  
  
2 5
 

翻译:

给出一个公式 

f[n]=(a*f[n-1]+b*f[n-2])%7;

输入a b n的值

输出f[n]的值


遇到这种求余数的题目 很有可能有规律或者循环节出现

ps:找出两个连续的数相同,则能够确定循环节的长度


图中1:循环之前的部分

图中2:循环长度

图中3:循环部分

#include<stdio.h>
#include<math.h>
int main (void)
{
    int a,b,n,f[1010];
    while(~scanf("%d%d%d",&a,&b,&n))
    {
        f[1]=f[2]=1;
        int beg,end;
        int flag=0;
        if(a==0&&b==0&&n==0)
            break;
        for(int i=3; i<=n&&!flag; i++)
        {
            f[i]=(a*f[i-1]+b*f[i-2])%7;
            for(int j=2; j<=i-1; j++)  //j<=i-1 是比较在i前一个数 j不能等于i 否则是自身重复比较
            {
                if(f[i]==f[j]&&f[i-1]==f[j-1])
                {
                    beg=j;
                    end=i;
                    flag=1;
                    break;
                }
            }
        }
        if(flag)//判定N是否在循环开始之后
            printf("%d\n",f[beg+(n-end)%(end-beg)]);//出现循环之后的数
        else
            printf("%d\n",f[n]);//f[n]是在出现循环之前的数
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值