Eclipse报错Java compiler level does not match the version of the installed Java project facet.解决办法

Java compiler level does not match the version of the installed Java project facet.
以前没有碰到过,检出项目的时候,项目中一直有把红叉,花了好几个小时才搞定,现把解决办法记下来,免得下次再遇到这个问题又要花那么多时间。

问题原因:

Facted Project 中的Java 版本设定与项目的Java编译器的compliance level设定不一致。

解决办法:

把两者设置成相同。

第一步:查看Compiler compliance level

右键Project | Properties | Java Compiler(type filter text输入compiler可快速定位),如下图所示:

这里写图片描述

根据图中显示可知,Compiler compliance level是6.0(当然您的项目该值很可能不是6.0)

第二步:修改Project Facets的Java值,使之和Compiler compliance level相同:

右键Project | Properties | Project Facets(type filter text输入facet可快速定位):

这里写图片描述
=>选中Java那行

=>点击Modify Project…按钮

=>修改Java的值,使之和Compiler compliance level相同(本例为6.0)

这里写图片描述

大功告成!

阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_24862137/article/details/74518797
文章标签: eclipse 插件
个人分类: Eclipse项目报错
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭