安卓VLC编译遇到的问题及解决办法

1、git需要请求用户

配置下你的git账号信息,如果没有需要自己去创建一个哦,比如

git config --global user.emaili xxx@qq.com

git config --global user.name xxx

配置完后需要删除掉vlc文件夹,不然git clone会出错

2、Source option 5 is no longer supported . Use 6 or later

如果出现这个问题,需要把jdk11版本(比如openjdk-11-jre-headless)删除,自己安装1.8版本,具体步骤如下:

①、sudo dpkg --list

找到openjdk-11开头的信息,注意第2列是包名

②、sudo apt --purge remove 包名(比如openjdk-11-jre-headless)

③、使用java -version检测是否是1.8.0开头的,比如

如果不是,确定第1、2步是否正确执行了,再安装JDK1.8版本

3、Could not resolve all files for configuraion...

如果遇到上面的问题,很大概率是网络的原因,导致下载jar包失败,可以再网络好的情况多执行下编译,或者导入Android Studio工具,让Android Studio帮我们去下载依赖的jar包,或者可以使用ssr代理去下载jar包

4、ERROR: cannot verify download.videolan.org's certificate, issued by ‘CN=Let's Encrypt Authority X3,O=Let's Encrypt,C=US’

解决办法:在下载命令后面加上“--no-check-certificate”,注意需要有空格隔开

发布了31 篇原创文章 · 获赞 2 · 访问量 4534
展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 大白 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览