android studio 配置Kotlin报错Error:Cause: org.gradle.api.internal.file.DefaultSourceDirectorySet.

Unable to find method 'org.gradle.api.internal.file.DefaultSourceDirectorySet。

Error:Cause: org.gradle.api.internal.file.DefaultSourceDirectorySet。

android studio 配置kt的时候报错,

点击tool ->kotlin->configure kotlin inproject 配置后:build.gradle文件如下:

buildscript {
    ext.kotlin_version = '1.0.0'

    repositories {
        google()
        jcenter()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:3.0.0'
        classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version"

        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

allprojects {
    repositories {
        google()
        jcenter()
    }
}

task clean(type: Delete) {
    delete rootProject.buildDir
}

我的原因是ext.kotlin_version = '1.0.0'的版本是默认生产的,不对,需要改

如何知道版本号填多少呢,点击file->settings->Plugins->Browse Repositories ->输入kotlin,找打自己安装的kotlin,上面显示了版本号v1.1.2.

(网上找的图,他的是1.1.2)

只需要将

ext.kotlin_version = '1.0.0'改成ext.kotlin_version = '1.1.2'即可

发布了55 篇原创文章 · 获赞 42 · 访问量 4万+
展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 大白 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览