POJ 2386 Lake Counting (DFS or BFS)

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3


题意:

有一个大小为N*M的园子,雨后积起了水。八连通的积水被认为是连接在一起的。请求出园子里总共有多少水洼?

***

*W*

***

W和*被认为是连接在一起的。


解题思路:

从任意的W开始,不停的把邻接的部分用‘.’代替。1次DFS之后与初始的这个W连接的所有W就都被替换成了‘.’,因此知道图中不存在W为止,主函数内总共进行DFS的次数就是答案了。


DFS代码:

#include <iostream>
using namespace std;

int N,M;
char filed[102][102];
int dx[8] = {1,1,1,0,-1,-1,-1,0},dy[8] = {1,0,-1,-1,-1,0,1,1}; 

void DFS(int n,int m)
{
	filed[n][m] = '.';

	for(int i = 0;i < 8;i++)
	{
		int nx = n + dx[i],ny = m + dy[i];
		if(0 <= nx && nx < N && 0 <= ny && ny < M && filed[nx][ny] == 'W')
			DFS(nx,ny);
	}
}

int main(int argc, char const *argv[])
{
	while(cin>>N>>M)
	{
		for(int i = 0;i < N;i++)
			for(int j = 0;j < M;j++)
				cin>>filed[i][j];

		int cnt = 0;
		for(int i = 0;i < N;i++)
			for(int j = 0;j < M;j++)
			{
				if(filed[i][j] == 'W')
				{
					DFS(i,j);
					cnt++;
				}
			}

		cout << cnt << endl;
	}
	return 0;
}



BFS代码:

#include <iostream>
#include <queue>
using namespace std;

int N,M;
char filed[102][102];
int dx[8] = {1,1,1,0,-1,-1,-1,0},dy[8] = {1,0,-1,-1,-1,0,1,1}; 
struct  node
{
	int x,y;
};

void BFS(int x,int y)
{
	queue<node> que;
	node p;
	p.x = x,p.y = y;
	que.push(p);
	filed[x][y] = '.';

	while(!que.empty())
	{
		node q = que.front();
		que.pop();
		for(int i = 0;i < 8;i++)
		{
			int nx = q.x + dx[i],ny = q.y + dy[i];
			if(0 <= nx && nx < N && 0 <= ny && ny < M && filed[nx][ny] == 'W')
			{
				filed[nx][ny] = '.';
				node temp;
				temp.x = nx,temp.y = ny;
				que.push(temp);
			}
		}
	}
}

int main(int argc, char const *argv[])
{
	while(cin>>N>>M)
	{
		for(int i = 0;i < N;i++)
			for(int j = 0;j < M;j++)
				cin>>filed[i][j];

		int cnt = 0;
		for(int i = 0;i < N;i++)
			for(int j = 0;j < M;j++)
			{
				if(filed[i][j] == 'W')
				{
					BFS(i,j);
					cnt++;
				}
			}

		cout << cnt << endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值