题目738:Calendar Game

39 篇文章 0 订阅
1 篇文章 0 订阅

题目链接:

http://acm.nyist.net/JudgeOnline/problem.php?pid=738

描述

Adam and Eve enter this year’s ACM International Collegiate Programming Contest. Last night, they played the Calendar Game, in celebration of this contest. This game consists of the dates from January 1, 1900 to November 4, 2001, the contest day. The game starts by randomly choosing a date from this interval. Then, the players, Adam and Eve, make moves in their turn with Adam moving first: Adam, Eve, Adam, Eve, etc. There is only one rule for moves and it is simple: from a current date, a player in his/her turn can move either to the next calendar date or the same day of the next month. When the next month does not have the same day, the player moves only to the next calendar date. For example, from December 19, 1924, you can move either to December 20, 1924, the next calendar date, or January 19, 1925, the same day of the next month. From January 31 2001, however, you can move only to February 1, 2001, because February 31, 2001 is invalid.

A player wins the game when he/she exactly reaches the date of November 4, 2001. If a player moves to a date after November 4, 2001, he/she looses the game.

Write a program that decides whether, given an initial date, Adam, the first mover, has a winning strategy.

For this game, you need to identify leap years, where February has 29 days. In the Gregorian calendar, leap years occur in years exactly divisible by four. So, 1993, 1994, and 1995 are not leap years, while 1992 and 1996 are leap years. Additionally, the years ending with 00 are leap years only if they are divisible by 400. So, 1700, 1800, 1900, 2100, and 2200 are not leap years, while 1600, 2000, and 2400 are leap years.

输入

The input consists of T test cases. The number of test cases (T) is given in the first line of the input. Each test case is written in a line and corresponds to an initial date. The three integers in a line, YYYY MM DD, represent the date of the DD-th day of MM-th month in the year of YYYY. Remember that initial dates are randomly chosen from the interval between January 1, 1900 and November 4, 2001.

输出

Print exactly one line for each test case. The line should contain the answer “YES” or “NO” to the question of whether Adam has a winning strategy against Eve. Since we have T test cases, your program should output totally T lines of “YES” or “NO”.

样例输入

3
2001 11 3
2001 11 2
2001 10 3

样例输出

YES
NO
NO

算法思想:

这道题是一道博弈论的题目,关键是如何找到规律,从题目中可以看到,能改变的只能是月份加1或者日期加1,考虑到日期和月份两者之和的变化只能是从奇数变为偶数或者偶数变为奇数,但有两个日期是特殊的,9月30号和11月30号,因为它们和可以从奇数变为奇数,9月30号(39)–>10月1号(11),11月30号(41)–>12月1号(13),故先手要赢就必须从和为偶数或者这两个日期中开始,这样后手选择的只有和为奇数的了,故后手不可能选择到2001 12 04.

但是这道题备NYOJ放在搜索里,目测深度搜索应该也可以解决,遍历所有的情况而已,但可能超时。

源代码

#include <iostream>
using namespace std;
int main()
{
    int yy, mm, dd, T;
    cin >> T;
    while (T--)
    {
        cin >> yy >> mm >> dd;
        if ((mm + dd) % 2 == 0 || (mm == 9 && dd == 30) || (mm == 11 && dd == 30))
        {
            cout << "YES" << endl;
        }
        else
            cout << "NO" << endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值