题目5:Binary String Matching

70 篇文章 1 订阅
39 篇文章 0 订阅

题目链接:

http://acm.nyist.net/JudgeOnline/problem.php?pid=5

描述

Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit

输入

The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.

输出

For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.

样例输入

3
11
1001110110
101
110010010010001
1010
110100010101011

样例输出

3
0
3

算法思想:

可以使用普通的循环遍历加回溯就可以,因为目标串最大10000个字符,模式串最大10个字符,故不会超时。当然也可以使用KMP算法。还有更简单的就是使用C++STL库中string类的find的函数。

源代码

/*
Author:杨林峰
Date:2017.10.20
NYOJ(5):Binary String Matching
*/
#include <iostream>
#include <string>
using namespace std;
int getNum(string pattern, string target)
{
    int len1 = pattern.length(), len2 = target.length();
    int i, j, ans = 0;
    for (i = 0; i <= len2 - len1; i++)
    {
        int tmp = i;
        for (j = 0; j < len1;)
        {
            //当模式串与目标串字符相等时,继续比较下一个字符
            if (pattern[j] == target[i])
            {
                i++;
                j++;
            }
            //否则,跳出循环
            else
            {
                break; 
            }
            //cout << i << " " << j << endl;
        }
        //判断目标串是否成功
        if (j >= len1)
            ans++;
        //回溯
        i = tmp;
        j = 0;
    }
    return ans;
}
int main()
{
    int N, ans;
    string pattern, target;
    cin >> N;
    while (N--)
    {
        cin >> pattern >> target;
        ans = getNum(pattern, target);
        cout << ans << endl;
    }
    return 0;
}

最优源代码


#include<iostream>
#include<string>
using namespace std;
int main()
{
    string s1,s2;
    int n;
    cin>>n;
    while(n--)
    {
        cin>>s1>>s2;
        unsigned int m=s2.find(s1,0);
        int num=0;
        while(m!=string::npos)
        {
            num++;
            m=s2.find(s1,m+1);
        }
        cout<<num<<endl;
    }
}        
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值