zoj1889

Ones

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Given any integer 0 <= n <= 10000 not divisible by 2 or 5, some multiple of n is a number which in decimal notation is a sequence of 1's. How many digits are in the smallest such a multiple of n?


Sample Input



9901


Sample Output

3
6
12



#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int solve(int n)
{
	int x=1;    //代表数字111……对n取模后的余数 
	for(int i=1;;i++)
	{
		if(x%n==0)return i;     //直到余数变为0 
		x=(x*10+1)%n;       //长度每增加一位余数变化 
	}
}
int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		printf("%d\n",solve(n));
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值