poj3517 & poj1781(约瑟夫环)

And Then There Was One
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 5329 Accepted: 2894

Description

Let’s play a stone removing game.

Initially, n stones are arranged on a circle and numbered 1, …, n clockwise (Figure 1). You are also given two numbers k and m. From this state, remove stones one by one following the rules explained below, until only one remains. In step 1, remove stone m. In step 2, locate the k-th next stone clockwise from m and remove it. In subsequent steps, start from the slot of the stone removed in the last step, make k hops clockwise on the remaining stones and remove the one you reach. In other words, skip (k − 1) remaining stones clockwise and remove the next one. Repeat this until only one stone is left and answer its number. For example, the answer for the case n = 8, k = 5, m = 3 is 1, as shown in Figure 1.


Initial state

Step 1

Step 2

Step 3

Step 4

Step 5

Step 6

Step 7

Final state
 
Figure 1: An example game

Initial state: Eight stones are arranged on a circle.

Step 1: Stone 3 is removed since m = 3.

Step 2: You start from the slot that was occupied by stone 3. You skip four stones 4, 5, 6 and 7 (since k = 5), and remove the next one, which is 8.

Step 3: You skip stones 1, 2, 4 and 5, and thus remove 6. Note that you only count stones that are still on the circle and ignore those already removed. Stone 3 is ignored in this case.

Steps 4–7: You continue until only one stone is left. Notice that in later steps when only a few stones remain, the same stone may be skipped multiple times. For example, stones 1 and 4 are skipped twice in step 7.

Final State: Finally, only one stone, 1, is on the circle. This is the final state, so the answer is 1.

Input

The input consists of multiple datasets each of which is formatted as follows.

n k m

The last dataset is followed by a line containing three zeros. Numbers in a line are separated by a single space. A dataset satisfies the following conditions.

2 ≤ n ≤ 10000, 1 ≤ k ≤ 10000, 1 ≤ m ≤ n

The number of datasets is less than 100.

Output

For each dataset, output a line containing the stone number left in the final state. No extra characters such as spaces should appear in the output.

Sample Input

8 5 3
100 9999 98
10000 10000 10000
0 0 0

Sample Output

1
93
2019


题意:给定n个人组成一个约瑟夫环,编号从1到n,最开始删除第m个人,此后删除向后第k个人,问最后留下来的人的编号。

思路:约瑟夫环,但是模拟的话由于数据太大会tle,所以需要用公式。

对 1,2,3,…,k,…,n 中删去k后重新编号得到 n-k+1,n-k+2,...,1,2,...,n-k. 发现有在重新编号的序列中编号为x的元素在原序列中编号为(k+x)%n,如果等于0的话对应n。

这样我们就能从末状态反推回最初的编号。

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int main()
{
	int n,m,k;
	while(~scanf("%d%d%d",&n,&k,&m)&&(n||k||m))
	{
		int x=1;
		for(int i=2;i<n;i++)
		{
			x=((k+x)%i==0)?i:((k+x)%i);
		}
		printf("%d\n",(m+x)%n==0?n:((m+x)%n));
	}
}


In Danger
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 3884 Accepted: 2020

Description

Flavius Josephus and 40 fellow rebels were trapped by the Romans. His companions preferred suicide to surrender, so they decided to form a circle and to kill every third person and to proceed around the circle until no one was left. Josephus was not excited by the idea of killing himself, so he calculated the position to be the last man standing (and then he did not commit suicide since nobody could watch). 

We will consider a variant of this "game" where every second person leaves. And of course there will be more than 41 persons, for we now have computers. You have to calculate the safe position. Be careful because we might apply your program to calculate the winner of this contest! 

Input

The input contains several test cases. Each specifies a number n, denoting the number of persons participating in the game. To make things more difficult, it always has the format "xyez" with the following semantics: when n is written down in decimal notation, its first digit is x, its second digit is y, and then follow z zeros. Whereas 0<=x,y<=9, the number of zeros is 0<=z<=6. You may assume that n>0. The last test case is followed by the string 00e0.

Output

For each test case generate a line containing the position of the person who survives. Assume that the participants have serial numbers from 1 to n and that the counting starts with person 1, i.e., the first person leaving is the one with number 2. For example, if there are 5 persons in the circle, counting proceeds as 2, 4, 1, 5 and person 3 is staying alive.

Sample Input

05e0
01e1
42e0
66e6
00e0

Sample Output

3
5
21
64891137

题意:给定一个数n,表示序号为1到n的数组成一个环,然后从2开始,每2个删一个,求最后留下的序号。

思路:这一题如果和上一题那样的话会tle,因为数据大小可以到1e10,所以打表找规律。发现每个n对应的序号等于(x-2^k)*2+1,其中2^k表示小于等于n的最大2的幂。


#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
typedef long long ll;
int main()
{
	int x,z;
	ll n;
	while(~scanf("%de%d",&x,&z)&&(x||z))
	{
		n=x;
		while(z)
		{
			n*=10;
			z--;
		}
		if(n==1)
		{
			printf("1\n");
			continue;
		}
		for(ll i=0;;i++)
		{
			if((2<<i)>n)
			{
				printf("%lld\n",(n-(2<<(i-1)))*2+1);
				break;
			}
		}
	}
}



  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值