hdu6438(贪心)

Buy and Resell

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1885    Accepted Submission(s): 683

Problem Description

The Power Cube is used as a stash of Exotic Power. There are n cities numbered 1,2,…,n where allowed to trade it. The trading price of the Power Cube in the i-th city is ai dollars per cube. Noswal is a foxy businessman and wants to quietly make a fortune by buying and reselling Power Cubes. To avoid being discovered by the police, Noswal will go to the i-th city and choose exactly one of the following three options on the i-th day:

1. spend ai dollars to buy a Power Cube
2. resell a Power Cube and get ai dollars if he has at least one Power Cube
3. do nothing

Obviously, Noswal can own more than one Power Cubes at the same time. After going to the n cities, he will go back home and stay away from the cops. He wants to know the maximum profit he can earn. In the meanwhile, to lower the risks, he wants to minimize the times of trading (include buy and sell) to get the maximum profit. Noswal is a foxy and successful businessman so you can assume that he has infinity money at the beginning.

Input

There are multiple test cases. The first line of input contains a positive integer T (T≤250), indicating the number of test cases. For each test case:
The first line has an integer n. (1≤n≤105)
The second line has n integers a1,a2,…,an where ai means the trading price (buy or sell) of the Power Cube in the i-th city. (1≤ai≤109)
It is guaranteed that the sum of all n is no more than 5×105.

Output

For each case, print one line with two integers —— the maximum profit and the minimum times of trading to get the maximum profit.

Sample Input

3

4

1 2 10 9

5

9 5 9 10 5

2

2 1

Sample Output

16 4 5 2 0 0

Hint

In the first case, he will buy in 1, 2 and resell in 3, 4. profit = - 1 - 2 + 10 + 9 = 16 In the second case, he will buy in 2 and resell in 4. profit = - 5 + 10 = 5 In the third case, he will do nothing and earn nothing. profit = 0

 

题意:给出一串数组,从左到右扫描一遍,可以在一个点做一次买进或者卖出的动作,也可以什么都不做,比如在4买入10卖出就获得的6的价值,求能获得的最多打价值,以及在这个价值时最少交易次数。

思路:贪心,维护一个优先队列,每个节点包含该节点的价格,有无和之前节点交易过,交易过的之前节点的价格。当一个新节点入优先队列时,先判断价格是否大于优先队列中价格最小的那个,如果不大于,无法交易,直接入队列;如果大于,且该价格最小节点没有和之前节点交易过,则交易,把该节点入优先队列,另一节点出优先队列,反之,就相当于该节点与之前与最小节点交易的节点交易。由于要交易次数最小,所以优先把交易过的节点放在优先队列前,这样交易次数不会变多。

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<vector>
#include<queue>
using namespace std;
typedef long long ll;
const int maxn = 1e5+10;
struct node
{
    int price;
    bool transaction;
    int lastprice;
    bool operator<(const node b)const 
    {
        if(price==b.price)return transaction<b.transaction;
        return price>b.price;
    }
}goods[maxn];
priority_queue<node> q;
int main()
{
    int t;
    int n;
    scanf("%d",&t);
    while(t--)
    {
        ll ans = 0;
        ll times = 0;
        while(!q.empty())q.pop();
        scanf("%d",&n);
        node ex;
        for(int i =1;i<=n;i++)
        {
            scanf("%d",&goods[i].price);
            goods[i].transaction = 0;
            if(!q.empty())
            {
                ex = q.top();
                if(ex.price>=goods[i].price)
                    q.push(goods[i]);
                else
                {
                    q.pop();
                    goods[i].transaction = 1;
                    if(ex.transaction)
                    {
                        ans -= (ex.price - ex.lastprice);
                        ans +=(goods[i].price - ex.lastprice);
                        ex.transaction = 0;
                        goods[i].lastprice = ex.lastprice;
                        q.push(goods[i]);
                        q.push(ex);
                    }
                    else
                    {
                        times += 2;
                        ans += (goods[i].price - ex.price);
                        goods[i].lastprice = ex.price;
                        q.push(goods[i]);
                    }
                }
            }
            else q.push(goods[i]);
        }
        printf("%lld %lld\n",ans,times);
    }
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值