JAVA第二次作业《组句游戏》

【问题描述】编程实现以下功能:要求用户从键盘逐行输入某个喜欢的颜色、喜欢的食物、喜欢的动物以及朋友的姓名。然后程序输出下面的内容。括号中的内容用用户输入来替换:

I had a dream that (姓名) ate a (颜色) (动物) and said that it tasted like (食物)!

【输入形式】颜色

食物

动物

朋友姓名

【输出形式】I had a dream that 姓名  ate a 颜色  动物  and said that it tasted like  食物 !

【样例输入】blue
hamburger
dog
Tom
【样例输出】I had a dream that Tom ate a blue dog and said that it tasted like hamburger!

【样例说明】

import java.util.Scanner;

public class MakeSentence {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        System.out.println("Please input your favorite color, food, animal and the best friend line by line:");
        String color = sc.nextLine();
        String food = sc.nextLine();
        String animal = sc.nextLine();
        String name = sc.nextLine();
        System.out.println("I had a dream that "+name+" ate a "+color+" "+animal+" and said that it tasted like "+food+"!");

    }
}

  • 3
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

夏佳怡

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值