大数据之大数相加

描述
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
A,B must be positive.
输入
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
输出
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation.

样例输入

2
1 2

112233445566778899 998877665544332211

样例输出

Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

代码如下:

package dashuju;

import java.util.Scanner;

public class dashuxiangjia {

  public static void main(String[] args) {
    Scanner sc = new Scanner(System.in);
    int  i = sc.nextInt();
    for (int j=1; j<=i;j++){
    String a, b;
    a = sc.next();
    b = sc.next();
    int changdu = a.length() - b.length() > 0 ? a.length() : b.length();    
    int[] aint = new int[changdu];
    int[] bint = new int[changdu];
    for (int i1 = 0; i1 < a.length(); i1++) {
      aint[a.length()-1-i1] = Integer.parseInt(a.substring(i1, i1 + 1));
    }
    for (int i1 = 0; i1 < b.length(); i1++) {
      bint[b.length()-1-i1] = Integer.parseInt(b.substring(i1, i1 + 1));
    }
    int[] sum = new int[changdu + 1];
    for (int i3 = 0; i3 < changdu; i3++) {
      sum[i3] = aint[i3] + bint[i3];
    }
    for (int i4 = 0; i4 < changdu; i4++) {
      sum[i4 + 1] = sum[i4] / 10 + sum[i4 + 1];
      sum[i4] = sum[i4] % 10;
    }
    int sumchangdu = changdu;
    while (sum[sumchangdu] == 0) {
      sumchangdu--;
    }
    System.out.println("Case "+j+":");
    System.out.print(a + " + " + b + " = ");
    for (int i5 = sumchangdu; i5 >= 0; i5--) {
      System.out.print(sum[i5]);
    }
  }
  }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值