hdu5762 Teacher Bo(曼哈顿距离的应用m = |x1-x2|+|y1-y2|.)

Teacher BoBo is a geography teacher in the school.One day in his class,he marked N points in the map,the i-th point is at (Xi,Yi).He wonders,whether there is a tetrad (A,B,C,D)(A<B,C<D,A≠CorB≠D) such that the manhattan distance between A and B is equal to the manhattan distance(曼哈顿距离) between C and D.

If there exists such tetrad,print “YES”,else print “NO”.

Input

First line, an integer T. There are T test cases.(T≤50)

In each test case,the first line contains two intergers, N, M, means the number of points and the range of the coordinates.(N,M≤105).

Next N lines, the i-th line shows the coordinate of the i-th point.(Xi,Yi)(0≤Xi,Yi≤M).

Output

T lines, each line is “YES” or “NO”.

Sample Input

2
3 10
1 1
2 2
3 3
4 10
8 8
2 3
3 3
4 4

Sample Output

YES
NO
/*
平面上,坐标(x1, y1)的点P1与坐标(x2, y2)的点P2的曼哈顿距离为:
m = |x1-x2|+|y1-y2|.
*/
#include<cstdio>
#include<cmath>
#include<string.h>
using namespace std;

int v[211111];

struct cor
{
    int x,y;
};
typedef struct cor data;
data s[100005];

int main()
{
    int n,m,i,j;
    long long distance;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        memset(v,0,sizeof(v));

        for(i=0; i<n; ++i)
            scanf("%d%d",&s[i].x,&s[i].y);

        int flag = 0;
        for(i=0; i<n; ++i)
        {
            for(j=i+1; j<n; ++j)
            {
                distance = abs(s[i].x-s[j].x)+abs(s[i].y-s[j].y);
                if(v[distance]==0)
                    v[distance] = i+1;
                else
                {
                    flag = 1;
                    break;
                }
            }
        }
        if(flag)
            printf("YES\n");
        else
            printf("NO\n");

    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

葛济维的博客

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值