(模拟)1241. 外卖店优先级——第十届蓝桥杯省赛C++A/C组,

1241. 外卖店优先级
“饱了么”外卖系统中维护着 N 家外卖店,编号 1∼N。

每家外卖店都有一个优先级,初始时 (0 时刻) 优先级都为 0。

每经过 1 个时间单位,如果外卖店没有订单,则优先级会减少 1,最低减到 0;而如果外卖店有订单,则优先级不减反加,每有一单优先级加 2。

如果某家外卖店某时刻优先级大于 5,则会被系统加入优先缓存中;如果优先级小于等于 3,则会被清除出优先缓存。

给定 T 时刻以内的 M 条订单信息,请你计算 T 时刻时有多少外卖店在优先缓存中。

输入格式
第一行包含 3 个整数 N,M,T。

以下 M 行每行包含两个整数 ts 和 id,表示 ts 时刻编号 id 的外卖店收到一个订单。

输出格式
输出一个整数代表答案。

数据范围
1≤N,M,T≤10^5,
1≤ts≤T,
1≤id≤N
输入样例:
2 6 6
1 1
5 2
3 1
6 2
2 1
6 2
输出样例:
1
样例解释
6 时刻时,1 号店优先级降到 3,被移除出优先缓存;2 号店优先级升到 6,加入优先缓存。

所以是有 1 家店 (2 号) 在优先缓存中。

#include <iostream>
#include <cstring>
#include <algorithm>

using namespace std;
const int N = 100005;
typedef pair<int,int> PII;
#define x first
#define y second
PII order[N]; //存储订单
int score[N],last[N]; //score存储每个店铺的优先级,last存储店铺上个订单的时间
bool v[N];

int main()
{
    int n,m,t;
    scanf("%d%d%d", &n, &m,&t);
    for (int i = 0; i < m; i ++ )
    {
        scanf("%d%d", &order[i].x, &order[i].y);
    }
    
    sort(order,order+m);

    
    for(int i=0; i<m; ++i){  //遍历每个订单
        int ts = order[i].first, id = order[i].second;
        if(ts!=last[id])//如果这个时间段有连续的订单,那么ts-last[id]==0
            score[id] -= (ts - last[id]-1);
        score[id] = max(score[id],0);  //最多减到0
        if(score[id] <= 3){  //如果小于等于3,移出优先缓存
            v[id] = false;
        }
        score[id] += 2;
        // cout<<id<<' '<<score[id]<<endl;
        if(score[id] > 5){  //如果大于5了,才能加入优先缓存
            v[id] = true;
        }
        last[id] = ts;
    }
    //更新t时刻状态
    for(int i=1; i<=n; ++i){
        // cout<<score[i]<<' '<<last[i]<<endl;
        if(last[i]!=t)
        score[i] -= (t - last[i]);
        if(score[i]<=3)
            v[i] = false;
    }
    int res = 0;
    for(int i=1; i<=n; ++i){
        if(v[i]){
            res++;
            // cout<<i<<' ';
        }
    }
    printf("%d\n",res);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

葛济维的博客

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值