FZU Problem 1215 Intervals

Problem 1215 Intervals

Accept: 80 Submit: 297 Time Limit: 1000 mSec Memory Limit : 32768 KB

img Problem Description

There is given the series of n closed intervals [ai,bi], where i=1,2,…,n. The sum of those intervals may be represented as a sum of closed pairwise non-intersecting intervals. The task is to find such representation with the minimal number of intervals. The intervals of this representation should be written in the output file in acceding order.

We say that the intervals [a,b] and [c,d] are in ascending order,if and only if a <= b < c <= d.

Task

Write a program which:

  • reads from the input file the description of the series of intervals
  • computes pairwise non-intersecting intervals satisfying the conditions given above
  • Output the computed intervals in ascending order

img Input

There several test cases. In the first line each case there is one integer n, 3 <= n <= 50000. This is the number of intervals. In the (i+1)-st line, 1 <= i <= n, there is a description of the interval [ai; bi] in the form of two integers ai and bi separated by a single space, which are respectively the beginning and the end of the interval, 1 <= ai <= bi <= 1000000.

img Output

The output of each case should contain descriptions of all computed pairwise non-intersecting intervals. In each line should be written a description of one interval. It should be composed of two integers, separated by a single space, the beginning and the end of the interval respectively. The intervals should be written into the output file in ascending order. Output a blank line after each case.

img Sample Input

5
5 6
1 4
10 10
6 9
8 10

img Sample Output

1 4
5 10

img Source

POI 01

解决方案

简单排序题

#include<stdio.h>
#include<algorithm>
using namespace std;
typedef struct node {
	int l, r;
	node(){}
	node(int l,int r):l(l),r(r){}
}node;
node list[50000];
//l值小的区间优先,l值相同r值大的优先
//这样排序完,按顺序读取时,碰到l值相同的区间不必再更新r值
bool listsort(node a, node b) {
	if (a.l == b.l) return a.r > b.r;
	return a.l < b.l;
}
int main() {
	int n, l, r, i;
	while (scanf("%d", &n) != EOF) {
		for (i = 0; i < n; i++) {
			scanf("%d%d", &l, &r);
			list[i] = node(l, r);
		}
		sort(list, list + n, listsort);
		//给l,r赋初值
		l = list[0].l; r = list[0].r;
		//只要区间的l值大于已存的r值即说明区间断开,则输出已存的l,r
		for (i = 1; i < n; i++) {
			if (list[i].l<=r&&list[i].r>r) r = list[i].r;
			else if (list[i].l > r) {
				printf("%d %d\n", l, r);
				l = list[i].l; r = list[i].r;
			}
		}
		//区间判断完毕,输出最后一个区间加一行空白行
		printf("%d %d\n\n", l, r);
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值