USACO 2.2 Party Lamps

题目:To brighten up the gala dinner of the IOI'98 we have a set of N (10 <= N <= 100) colored lamps numbered from 1 to N.

The lamps are connected to four buttons:

  • Button 1: When this button is pressed, all the lamps change their state: those that are ON are turned OFF and those that are OFF are turned ON.
  • Button 2: Changes the state of all the odd numbered lamps.
  • Button 3: Changes the state of all the even numbered lamps.
  • Button 4: Changes the state of the lamps whose number is of the form 3xK+1 (with K>=0), i.e., 1,4,7,...

A counter C records the total number of button presses.

When the party starts, all the lamps are ON and the counter C is set to zero.

You are given the value of counter C (0 <= C <= 10000) and the final state of some of the lamps after some operations have been executed. Write a program to determine all the possible final configurations of the N lamps that are consistent with the given information, without repetitions.

PROGRAM NAME: lamps

INPUT FORMAT

No lamp will be listed twice in the input.

Line 1:N
Line 2:Final value of C
Line 3:Some lamp numbers ON in the final configuration, separated by one space and terminated by the integer -1.
Line 4:Some lamp numbers OFF in the final configuration, separated by one space and terminated by the integer -1.

SAMPLE INPUT (file lamps.in)

10
1
-1
7 -1

In this case, there are 10 lamps and only one button has been pressed. Lamp 7 is OFF in the final configuration.

OUTPUT FORMAT

Lines with all the possible final configurations (without repetitions) of all the lamps. Each line has N characters, where the first character represents the state of lamp 1 and the last character represents the state of lamp N. A 0 (zero) stands for a lamp that is OFF, and a 1 (one) stands for a lamp that is ON. The lines must be ordered from least to largest (as binary numbers).

If there are no possible configurations, output a single line with the single word `IMPOSSIBLE'

SAMPLE OUTPUT (file lamps.out)

0000000000
0101010101
0110110110
In this case, there are three possible final configurations:
  • All lamps are OFF
  • Lamps 1, 4, 7, 10 are OFF and lamps 2, 3, 5, 6, 8, 9 are ON.
  • Lamps 1, 3, 5, 7, 9 are OFF and lamps 2, 4, 6, 8, 10 are ON.

分析:
一、 开关1以1为周期,开关2和3以2为周期,开关4以3为周期,所以灯是以6=gcd(1,2,3)为周期进行变化的,可仅仅考虑6盏灯的情况。
二、每个开关按两次=没按,所以可将C不断减2直到小于5,得到有效按动开关的总次数。

light[k] 记录了从初始状态63(”111111“)经过c步能否到k,能则为1,不能则为0。 用深搜。这个数组最多64个元素(000000~111111)。

mark[6]记录题目中限制条件,因为6位一循环,7和1是一样的,8和2是一样的,等等。。

符合条件的字符串应该满足: light[k] == 1 并且 满足题目要求的限制条件。

最后,将字符串排序后输出。。

写的比较挫,因为最后我需要把满足条件字符串存起来,然后排序。 要是能不排序,直接输出,就好了。要是有人有方法,请告诉我。。。

代码:
/*
ID: gjj50201
LANG: C++
TASK: lamps
*/

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<cmath>
#include<vector>
#include<algorithm>
#define b1 63
#define b2 21
#define b3 42
#define b4 9
using namespace std;
int N,C;
int light[64];
int mark[6];
vector <string> ans;

//搜索c步能达到的所有可能状态
void dfs(int k, int steps){
	if(!steps){
		light[k] = 1;
		return;
	}
	int t;
	t = k^b1; dfs(t,steps-1);
	t = k^b2; dfs(t,steps-1);
	t = k^b3; dfs(t,steps-1);
	t = k^b4; dfs(t,steps-1);
}

//检查是否满足题目要求的限制条件
int ok(int k){
	for(int i=0;i<6;i++)
		if( mark[i]!=-1 && (k&(1<<i)) != (mark[i]<<i))
			return 0;
	return 1;
}

//扩展成需要的N位串
string convert(int k){
	int ans[6];

//把十进制转化成二进制,并且相应位子上的数字存起来
	for(int i=0;i<6;i++)
        ans[i] = (k & (1<<i)) / (1<<i);  
     
    
    string result = "";
	for(int i = 0; i<N ;i++)
		result += ans[i%6] + '0';
    return result;
}


int main(){
	freopen("lamps.in","r",stdin);
    freopen("lamps.out","w",stdout);
    cin>>N>>C;
    while(C>4) C-=2;

    for(int i=0;i<6;i++)
    	mark[i] = -1;
    
    int tmp;
    cin>>tmp;
    while(tmp!=-1) {mark[(tmp-1)%6] = 1; cin>>tmp;}
    
    cin>>tmp;
    while(tmp!=-1) {mark[(tmp-1)%6] = 0; cin>>tmp;}

    dfs(63,C);

    for(int i=0;i<64;i++)
    	if(light[i] && ok(i))
    		ans.push_back(convert(i));

    
    if(!ans.size())
    	cout<<"IMPOSSIBLE"<<endl;
    else{
        sort(ans.begin(),ans.end());
        vector<string>::iterator it;
        for(it = ans.begin();it!=ans.end();it++)
            cout<<*it<<endl;
    }
    return 0;
}


 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值