USACO 2.3 Zero Sum

题目:

Zero Sum

Consider the sequence of digits from 1 through N (where N=9) in increasing order: 1 2 3 ... N.

Now insert either a `+' for addition or a `-' for subtraction or a ` ' [blank] to run the digits together between each pair of digits (not in front of the first digit). Calculate the result that of the expression and see if you get zero.

Write a program that will find all sequences of length N that produce a zero sum.

PROGRAM NAME: zerosum

INPUT FORMAT

A single line with the integer N (3 <= N <= 9).

SAMPLE INPUT (file zerosum.in)

7

OUTPUT FORMAT

In ASCII order, show each sequence that can create 0 sum with a `+', `-', or ` ' between each pair of numbers.

SAMPLE OUTPUT (file zerosum.out)

1+2-3+4-5-6+7
1+2-3-4+5+6-7
1-2 3+4+5+6+7
1-2 3-4 5+6 7
1-2+3+4-5+6-7
1-2-3-4-5+6+7

思路: 水题。深搜,生成字符串,然后判断该字符串是否符合要求,输出。

代码:

/*
ID: gjj50201
LANG: C++
TASK: zerosum
*/

#include <stdio.h>
#include <string>
#include <iostream>
#include <algorithm>
#include <queue>
using namespace std;
int n;
char digits[10] = {'0','1','2','3','4','5','6','7','8','9'};

queue<string> ans;
bool check(string s){
	int sum = 0;
	queue <char> op;
	queue <int> num;
	for(int i=0;i<=s.size();i++){
		if(i == s.size())
			num.push(sum);
		else if(s[i] == '+' || s[i] == '-'){
			op.push(s[i]);
			num.push(sum);	
			sum = 0;		
		}
		else if(s[i]>='1' && s[i]<= '9')
			sum = sum*10 + s[i] - '0';
	}

	int d1,d2;
	d1 = num.front();
	num.pop();
	while(!op.empty()){
		char o;
		o = op.front();
		op.pop();
		d2 = num.front();
		num.pop();
		switch(o){
			case '+':{
				d1  = d1 + d2;
				break;
			}
			case '-':{
				d1 = d1 - d2;
				break;
			}

		}
	}
    if(d1 == 0){
		return true;		
	}
	else
		return false;
}

void dfs(string s,int k){
	s = s + digits[k];
	if(k == n){
		if(check(s))
			ans.push(s);
		return;
	}
	dfs(s+' ',k+1);
	dfs(s+'+',k+1);
	dfs(s+'-',k+1);

	return;
}

int main(){
	freopen("zerosum.in","r",stdin);
	freopen("zerosum.out","w",stdout);
	cin>>n;
	dfs("",1);
	while(!ans.empty()){
		cout<<ans.front()<<endl;
		ans.pop();
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值