3.对称子字符串

Description
Given a string ‘str’ of digits, find length of the longest substring of ‘str’, such that the length of the substring is 2k digits and sum of left k digits is equal to the sum of right k digits.

Input
输入第一行是测试用例的个数,后面每一行表示一个数字组成的字符串,例如:“123123”

Output
输出找到的满足要求的最长子串的长度。例如,给定的例子长度应该是 6。每行对应一个用例的结果。

Sample Input 1
1
1538023

Sample Output 1
4

def solution(l):
    if len(l) <= 1:
        return 0
    else:
        res = 0
        for i in range(1, len(l)):
            step = 1
            while i - step >= 0 and i + step - 1 < len(l):
                if sum(l[i-step:i]) == sum(l[i:i+step]) and step > res:
                    res = step
                step += 1
        return res * 2
    

if __name__ == '__main__':
    n = int(input())
    for i in range(n):
        l = list(map(int, input()))
        result = solution(l)
        print(result)
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值