myeclipse配置高版本的tomcat

一、起因:

   我安装的MyEclipse是6.6版本的,内置的JDK是1.5版本的,而安装的tomcat版本是8.5.9的。今天用MyEclipse配置tomcat8.5.9时才发现找不到tomcat8.X,如图所示。                          

                               

于是试着选择Tomcat6.x。部署Servlet,运行服务器。结果出现了如下错误。


为之奈何?我们可以用Tomcat8.x把Tomcat5.x给替换掉。


二、步骤:

    windows→Preferences→MyEclipseEnterprise Workbench→Servers→Tomcat(由于MyEclipse没有提供Tomcat8.x的服务选项,就用tomcat5.x添加运行tomcat8)

1、将Tomcat server设置为Enable。

2、在Tomcat home directory点击browser选择tomcat的安装路径(E:\tomcat8.5.9)

3、在Tomcat5.x下的JDK目录,在后边"Tomcat JDK name"出点击"add"按钮,添加JDK,在弹出的窗口点"Browse"找到安装路径,点击"ok"。如图所示:              

       

               

4、点击Paths目录,在右边Prepend to classpath 和Append to classpath处点击"Add JAR/ZIP",添加jar包tomcat-juli.jar。点击"ok"

       

相关配置成功之后,Servlet可以成功运行。


          




已标记关键词 清除标记
相关推荐
©️2020 CSDN 皮肤主题: 编程工作室 设计师:CSDN官方博客 返回首页