单调递增最长子序列

单调递增最长子序列

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 4
描述
求一个字符串的最长递增子序列的长度
如:dabdbf最长递增子序列就是abdf,长度为4
输入
第一行一个整数0<n<20,表示有n个字符串要处理
随后的n行,每行有一个字符串,该字符串的长度不会超过10000
输出
输出字符串的最长递增子序列的长度
样例输入
3
aaa
ababc
abklmncdefg
样例输出
1
3
7
#include<iostream>
#include<stdio.h>
#include<math.h>
#include<string>
#include<algorithm>
using namespace std;

struct Mystruct
{
    char ch;
    int maxLengh;
};
int cmp(int n,Mystruct *m,char ch)
{
    for (int i = 0; i <= n; i++)
    {
        if (m[i].ch < ch)
        {
            if (m[n+1].maxLengh<(m[i].maxLengh + 1))
                m[n+1].maxLengh = m[i].maxLengh + 1;
        }
    }
    return m[n+1].maxLengh;
}
int main()
{
    int n;
    cin >> n;
    while (n--)
    {
        int max = 1;
        int maxplace = 0;
        int len = 0;
         char str[100001];
        cin >> str;
        // len = strlen(str);
         len = sizeof(str)-1;
        Mystruct strsruct[100001];
        for (int i = 0; i < len; i++)
        {
            strsruct[i].ch = str[i];
            strsruct[i].maxLengh = 1;
        }
        for (int i = 0; i < len-1; i++)
        {
            int temp = cmp(i, strsruct, strsruct[i + 1].ch);
            if (max<temp)
            max = temp;
        }
        cout << max << endl;
    }
    
}

会时间超限 很烦
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值