ACM 规律递归
Problem Description
A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
Output
For each test case, print the value of f(n) on a single line.
Sample Input
1 1 3
1 2 10
0 0 0
Sample Output
2
5
Author
CHEN, Shunbao
Source
ZJCPC2004
源码:
#include<iostream>
using namespace std;
int re[10000];
int main()
{
int a,b,n;
re[1]=1;re[2]=1;
while(cin>>a>>b>>n&&(a||b||n)){
int i;
for(i=3;i<10000;i++){
re[i]=(a*re[i-1]+b*re[i-2])%7;
if(re[i]==1&&re[i-1]==1)
break;
}
n=n%(i-2);
re[0]=re[i-2]; //这里一直不明白
cout<<re[n]<<endl;
}
return 0;
}