1258:Agri-Net(最小生成树)

1258:Agri-Net

总时间限制: 1000ms 内存限制: 65536kB
描述
Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.
输入
The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.
输出
For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.
样例输入
4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0
样例输出
28

#include <iostream>
using namespace std;
//http://bailian.openjudge.cn/practice/1258/
//对于题意感觉有些不理解,比如给定的矩阵肯定两两之间是有距离的么?
//为什么这样给定了就不需要都初始化为INF了呢,而且对于对角线上的数字也不需要特殊处理,为什么? 
const int INF=510000; 
int n,path[110][110],d[110],res;
bool used[110];
void prim(){
    for(int i=0;i<n;i++){
        d[i]=INF;
        used[i]=false;
    }
    res=0;
    d[0]=0;
    while(true){
        int v=-1;
        for(int i=0;i<n;i++){
            if(!used[i]&&(v==-1||d[v]>d[i])){
                v=i;
            }
        }
        if(v==-1)break;
        res+=d[v];
        used[v]=true;
        for(int i=0;i<n;i++){
            d[i]=min(d[i],path[v][i]);
        }
    }
}
int main(int argc, char *argv[]) {
    while(cin>>n){
        if(n==0)break;
        for(int i=0;i<n;i++){
            for(int j=0;j<n;j++){
                cin>>path[i][j];
            }
        }
        prim();
        cout<<res<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值