Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input
Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.
Output
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input-1000000 9Sample Output
-999,991
思路:首先肯定想到要用1000来取余数然后加上逗号输出,但是先取出来的余数要最后才输出,因此自然想到栈,那么用个递归就很容易解决了
#include <iostream>
#include <iomanip>
#include <cmath>
using namespace std;
void form(int n){
if(abs(n)<1000)
cout<<n;
else{
form(n/1000);
cout<<','<<setw(3)<<setfill('0')<<abs(n%1000);
}
}
int main()
{
int a,b,sum;
cin>>a>>b;
sum = a+b;
form(sum);
return 0;
}