1102. Invert a Binary Tree (25) PAT甲级刷题

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node from 0 to N-1, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:
8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6
Sample Output:
3 7 2 6 4 0 5 1

6 5 7 4 3 2 0 1

思路:交换,层序,中序。。。传统的交换用递归就行了,不过这里好像可以直接在输入数据时就将左右孩子顺序交换一下就行了。。。

#include <iostream>
#include <vector>
#include <queue>
using namespace std;

struct TNode{
    char left;
    char right;
};

void invert(TNode tree[],int root){
    char temp;
    if(tree[root].left!='-')
        invert(tree,tree[root].left-'0');
    if(tree[root].right!='-')
        invert(tree,tree[root].right-'0');
    temp = tree[root].left;
    tree[root].left = tree[root].right;
    tree[root].right = temp;
}

void inorder(TNode tree[],int root){
    static int cnt = 0;
    if(tree[root].left!='-')
        inorder(tree,tree[root].left-'0');
    if(cnt==0)
        cout<<endl<<root;
    else
        cout<<' '<<root;
    ++cnt;
    if(tree[root].right!='-')
        inorder(tree,tree[root].right-'0');
}

int main()
{
    int n;
    cin>>n;
    TNode tree[10];
    vector<int> root;
    for(int i=0;i<n;++i){
        root.push_back(i);
        cin>>tree[i].left>>tree[i].right;
    }
    for(int i=0;i<n;++i){
        if(tree[i].left!='-')
            root[tree[i].left-'0'] = -1;
        if(tree[i].right!='-')
            root[tree[i].right-'0'] = -1;
    }
    int rt;
    for(int i=0;i<n;++i){
        if(root[i]!=-1)
            rt = i;
    }
    invert(tree,rt);
    queue<TNode> q;
    TNode t;
    cout<<rt;
    q.push(tree[rt]);
    while(!q.empty()){
        t = q.front();
        q.pop();
        if(t.left!='-'){
            cout<<' '<<t.left;
            q.push(tree[t.left-'0']);
        }
        if(t.right!='-'){
            cout<<' '<<t.right;
            q.push(tree[t.right-'0']);
        }
    }
    inorder(tree,rt);
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值