maven reimport all maven projects to jdk 1.5

Maven更新idea编译版本变成1.5


最近在在使用maven的时候,发现每修改一次pom文件就会导致工程的编译版本变成1.5版本,让人头大。
后来发现是maven的默认jdk配置导致的,如果你在pom里面没有指定jdk版本的话如下配置:

<properties>
	<java.version>1.X</java.version>
	<maven.compiler.source>1.X</maven.compiler.source>
	<maven.compiler.target>1.X</maven.compiler.target>
</properties>

就会导致走向maven配置的版本,假如这个时候你没有Maven里面没有配置的话就会使用默认的jdk1.5.

所以解决方法有两种,一种是在jdk上面指定编译版本呢。一种是修改maven的默认编译版本。

修改maven的默认编译版本

首先找到maven配置,如果使用的idea可以在File—>Setting—>Build,Execution,Deployment—>Build Tools—>Maven里面找到配置的Maven home direcotry
maven配置
如果使用的idea自带的版本,User Seeting files里面是找不到setting.xml这个文件的。
需要在Maven home direcotry 里面看看idea的插件地址。然后在插件里面修改conf文件下下面的setting.xml
在profiles节点下面增加下面配置就可以修改默认版本。

       <profile>
			<id>jdk11</id>
			<activation>
			<activeByDefault>true</activeByDefault>
				<jdk>1.8</jdk>
			</activation>
			<properties>
				<maven.compiler.source>1.11</maven.compiler.source>
				<maven.compiler.target>1.11</maven.compiler.target>
				<maven.compiler.compilerVersion>1.11</maven.compiler.compilerVersion>
			</properties>
		</profile>
发布了45 篇原创文章 · 获赞 6 · 访问量 5万+
展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 大白 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览