[POJ - 2386] Lake Counting (简单的DFS)

17 篇文章 0 订阅
10 篇文章 0 订阅

题目传送门:点传送
来源:USACO 2004 November
Time Limit: 1000MS
Memory Limit: 65536K

Description

Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (’.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.
Given a diagram of Farmer John’s field, determine how many ponds he has.

Input

  • Line 1: Two space-separated integers: N and M

  • Lines 2…N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do
    not have spaces between them.

Output

  • Line 1: The number of ponds in Farmer John’s field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint
OUTPUT DETAILS:
There are three ponds: one in the upper left, one in the lower left,and one along the right side.

解析:
一个鱼塘定义:一个W和它八连通方向(上下左右+四个45度方向)连成的一块W算一个鱼塘。如样例,有三块W,所以是三个鱼塘。比较明显的一个图的搜索,这题我用DFS的做法。

代码

#include <stdio.h>
char a[100][100];
int N,M;
int main(void)
{
    int dfs(int x,int y);
    int i,j,cnt=0;
    scanf("%d%d",&N,&M);
    getchar();//清除换行
    for(i=0;i<N;i++)
    {
        for(j=0;j<M;j++)
            a[i][j]=getchar();//读入数据
        getchar();//清除换行
    }
    for(i=0;i<N;i++)
        for(j=0;j<M;j++)
            if(a[i][j]=='W') dfs(i,j),cnt++;//记录W块数
    printf("%d\n",cnt);
}
int dfs(int x,int y)
{
    a[x][y]='.';//把搜过的W直接变成.就不用另外建 标记数组
    int m,n,nx,ny;
    for(m=-1;m<=1;m++)
        for(n=-1;n<=1;n++)
        {
            if(m==0&&n==0)continue;// 自己站着的点就跳过
            nx=x+m;
            ny=y+n;
            if(nx>=0&&nx<N&&ny>=0&&ny<M&&a[nx][ny]=='W')//满足条件的继续搜
            dfs(nx,ny);
        }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值