浙江科技学院第十三届程序设计竞赛1008

A Heavy Rainy Day

Time Limit : 3000/1000ms (Java/Other)   Memory Limit : 65535/32768K (Java/Other)
Total Submission(s) : 475   Accepted Submission(s) : 124
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

As you know, Hangzhou always rains heavily, especially in Xiaoheshan area, which does annoy ACMers for a longer time. One day, N hardworking ACMers were playing League of Legends in the lab, of course not include me, while it was raining cats and dogs. Everyone wanted to come back to the department where they were living together, but no one wanted to be soaked without umbrella. Unfortunately, they only had one umbrella, which is too small to take more than two individuals. The time that everyone needs to spent to go to the department is known. If two guys came back together, it will take the longer time of this two guys. The question is the earliest time they come back to the department.

Input

The first line contains an integer T(1<=T<=20),which is the number of test cases.
For each testcase:
The first line contains one integer N ,1<=N<=1000, present N ACMers want to come back,
The second line contains N integers Si, present the time the ith ACMers need.

Output

The shortest time they need to come to the department.

Sample Input

1
4
1 2 5 10

Sample Output

17
这道题需要四个一组考虑最优解
<span style="font-family:KaiTi_GB2312;font-size:24px;">#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<cmath>
using namespace std;
int a[1010];
int main()
{
	int n;
	scanf("%d",&n);
	while(n--)
	{
		int m;
		scanf("%d",&m);
		for(int i=0;i<m;i++)
		{
			scanf("%d",&a[i]);
		}
		sort(a,a+m);
		int sum=0,q,p;
		while(m>3)
		{
		    q=a[0]+a[1]*3+a[m-1];
		    p=a[0]*2+a[1]+a[m-1]+a[m-2];
			if(q>p)
			sum+=p-a[1];
			else sum+=q-a[1];
			m-=2;
		}
		if(m==1)
		sum+=a[0];
		if(m==2)
		sum+=a[1];
		if(m==3)
		sum+=a[0]+a[1]+a[2];
		printf("%d\n",sum);
	}
	return 0;
}</span>







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值