hdu 1709 母函数

The Balance

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7220    Accepted Submission(s): 2980


Problem Description
Now you are asked to measure a dose of medicine with a balance and a number of weights. Certainly it is not always achievable. So you should find out the qualities which cannot be measured from the range [1,S]. S is the total quality of all the weights.
 

Input
The input consists of multiple test cases, and each case begins with a single positive integer N (1<=N<=100) on a line by itself indicating the number of weights you have. Followed by N integers Ai (1<=i<=N), indicating the quality of each weight where 1<=Ai<=100.
 

Output
For each input set, you should first print a line specifying the number of qualities which cannot be measured. Then print another line which consists all the irrealizable qualities if the number is not zero.
 

Sample Input
  
  
3 1 2 4 3 9 2 1
 

Sample Output
  
  
0 2 4 5
题意:有一个天平来称物体重量,有n种砝码,每种砝码只有一个,由于每个砝码都可以放在左右两边,所以不仅要相加还要相减。

用到母函数(1+x^n1)*(1+x^n2)*……*(1+x^nn),由于能力有限只能计算出那个物体能称出来,不能算出方法有几种。

#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<cmath>
using namespace std;
int a[10001];
int c1[10001],c2[10001];
int c3[10001];
int main()
{
	int n;
	while(scanf("%d",&n)==1)
	{
		memset(c1,0,sizeof(c1));
		memset(c2,0,sizeof(c2));
		int sum=0;
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
			sum+=a[i];
		}
		c1[0]=1;c1[a[1]]=1;
		for(int i=2;i<=n;i++)
		{
		    for(int j=0;j<=sum;j++)
		    {
		    	for(int k=0;k+j<=sum&&k<=a[i];k+=a[i])
		    	{
		    		c2[abs(j-k)]+=c1[j];
		    		c2[j+k]+=c1[j];
				}
			}
			for(int j=0;j<=sum;j++)
			{
				c1[j]=c2[j];c2[j]=0;
			}
		}
		int cnt=0;
		for(int i=1;i<=sum;i++)
		{
			if(c1[i]==0)
			{
				c3[++cnt]=i;
			}
		}
		if(cnt==0)
		{
			printf("0\n");
		}
		else{
			printf("%d\n",cnt);
		  for(int i=1;i<=cnt;i++)
		  {
		  	if(i!=1)
		  	printf(" ");
		  	 printf("%d",c3[i]);
		  }
		  printf("\n");	
		}
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值