poj 2104 K-th Number

K-th Number
Time Limit: 20000MS
Memory Limit: 65536K
Total Submissions: 45753
Accepted: 15218
Case Time Limit: 2000MS

Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment. 
That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?" 
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

Input

The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000). 
The second line contains n different integer numbers not exceeding 109 by their absolute values --- the array for which the answers should be given. 
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it --- the k-th number in sorted a[i...j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

Hint

This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.

Source

Northeastern Europe 2004, Northern Subregion

属于线段树的划分树一道题,构建划分树需要先构建一个新数组,再将原数组排列,然后找出中位数,小于等于中位数的划分到左子树,大于中位数划分到右子树,并同时记录每个子树所被划分的数量,查询时通过判断数量即可找到

<span style="font-size:24px;">#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<cmath>
using namespace std;
int a[100001],tem[20][100001],sum[20][100001];
void build(int l,int r,int d)
{
	if(l==r)
	return ;
	int mid=(l+r)/2,lt=l,lr=mid+1;
	for(int i=l;i<=r;i++)
	{
		sum[d][i]=sum[d][i-1];
		if(tem[d][i]<=a[mid]&<<=mid)
		{
			tem[d+1][lt++]=tem[d][i];
			++sum[d][i];
		}
		else{
			tem[d+1][lr++]=tem[d][i];
		}
	}
	build(l,mid,d+1);
	build(mid+1,r,d+1);
}
int query(int s,int e,int k,int l,int r,int d)
{
	if(s==e)
	return tem[d][s];
	int mid=(l+r)/2;
	int ls,le;
	ls=sum[d][s-1]-sum[d][l-1];
	le=sum[d][e]-sum[d][s-1];
	if(le>=k)
	{
		return query(l+ls,l+ls+le-1,k,l,mid,d+1);
	}
	int rs,re;
	rs=s-ls-l;
//	rs=s-ls-l+1;错了 
	re=e-s-le+1;
	return query(mid+rs+1,mid+re+rs,k-le,mid+1,r,d+1);
//	return query(mid+rs,mid+re+rs,k-le,mid+1,r,d+1);错了 
}
int main()
{
	int m,n;
	scanf("%d%d",&n,&m);
	for(int i=1;i<=n;i++)
	{
		scanf("%d",&a[i]);
		tem[0][i]=a[i];
	}
	sort(a+1,a+n+1);
	build(1,n,0);
	int l,r,k;
	while(m--)
	{
		scanf("%d%d%d",&l,&r,&k);
		printf("%d\n",query(l,r,k,1,n,0));
	}
	return 0;
}
</span>






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值