UVa 1583 - Digit Generator

https://uva.onlinejudge.org/external/15/1583.pdf

For a positive integer N , the digit-sum of N is defined as the sum of N itself and its digits. When M is the
digitsum of N , we call N a generator of M .
For example, the digit-sum of 245 is 256 (= 245 + 2 + 4 + 5). Therefore, 245 is a generator of
256.
Not surprisingly, some numbers do not have any generators and some numbers have more than one generator.
For example, the generators of 216 are 198 and 207.
You are to write a program to find the smallest generator of the given integer.
Input
Your program is to read from standard input. The input consists of T test cases. The number of test cases T is
given in the first line of the input. Each test case takes one line containing an integer N , 1 N 100, 000 .
Output
Your program is to write to standard output. Print exactly one line for each test case. The line is to contain a
generator of N for each test case. If N has multiple generators, print the smallest. If N does not have any
generators, print 0.
The following shows sample input and output for three test cases.
Sample Input
3
216
121
2005
Sample Output
198
0
1979
Seoul 2005-2006

题意:
如果x加上x的各位数字之和得到y,那么就说x是y的生成元,现在给你一个N,让你求N的最小生成元。

#include <iostream>
#include <sstream>
#include <iomanip>
#include <vector>
#include <deque>
#include <list>
#include <set>
#include <map>
#include <stack>
#include <queue>
#include <bitset>
#include <string>
#include <numeric>
#include <algorithm>
#include <functional>
#include <iterator>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <cctype>
#include <complex>
#include <ctime>
#define INF 0x3f3f3f3f
#define eps 1e-6
#define p(x) printf("%d\n", x)
#define k(x) printf("Case %d: ", ++x)
#define mes(x, d) memset(x, d, sizeof(x))
#define s(x) scanf("%d", &x)

typedef long long LL;

const double pi = acos(-1.0);
const long long mod = 1e9 + 7;


using namespace std;

int ans[100005];
int main()
{
    //freopen("int.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    memset(ans,0,sizeof(ans));
    for(int i = 1;i < 100005;i++)
    {
        int x = i,y = i;
        while(x > 0)
        {
            y += x % 10;
            x /= 10;
        }
        if(ans[y] == 0 || i < ans[y])
            ans[y] = i;
    }
    int T,N;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&N);
        printf("%d\n",ans[N]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值