Constructing Roads
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 21881 Accepted: 9295
Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.
We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.
Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
Sample Input
3
0 990 692
990 0 179
692 179 0
1
1 2
Sample Output
179
我的想法是 直接录入上三角 可以节省空间 然后用并查集+克鲁斯卡尔算法 生成树 样例过了 voj没过 求大佬们 帮忙看看
发现问题 也更正了 判等用了 = 而不是 == 感觉好丢脸
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
const int N = 1000+5;
struct Node{
int u;
int v;
int w;
bool operator < (const Node &n){
return w < n.w;
}
}node[5055];
int uf[N];
int find(int x){
if(uf[x]==-1) return x;
return uf[x] = find(uf[x]);
}
int main()
{
int num;
cin >> num;
int vexNum = 0;
for(int i = 1; i <= num;i++){
for(int j = 1; j <= num;j++){
int temp;
cin >> temp;
if(j>i){
node[vexNum].u = i;
node[vexNum].v = j;
node[vexNum++].w = temp;
}
}
}
sort(node,node+vexNum);
memset(uf,-1,sizeof(uf));
int n,cnt,t1,t2;
long long ans;
cnt =ans = 0;
cin >> n;
for(int i = 0; i < n;i++){
int s1,s2;
cin >> s1 >> s2;
t1 = find(s1);
t2 = find(s2);
if(t1!=t2){
uf[t1] = t2;
cnt++;
}
}
for(int i = 0; ;i++ ){
t1 = find(node[i].u);
t2 = find(node[i].v);
if(t1!=t2){
uf[t1] = t2;
cnt++;
ans += node[i].w;
if(cnt == num-1)
break;
}
}
cout << ans <<endl;
return 0;
}