Poj 1611 The Suspects【并查集】

POJ The Suspects

 POJ - 1611 

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

 

题目大意

 n学生分为K组 然后告诉你 每个组的人数和成员  找出和 0 成员有直接或间接联系的 同学的个数

解题思路

经典并查集    将所有学生存入并查集  在结尾加一个遍历  Find(i) = uf[0] 即与0 有关

因为与0有关  所以可以调整一下uf数组的范围

心得

本菜鸡原以为 一个集合需要开一个并查数组(手动害羞)  现在自己理解的 并查集是靠连接关系将多个集合合并

一个并查数组可以容纳多个集合

 

上代码

#include<iostream>

using namespace std;

const int N = 30000;

int uf[N];

void UfInit(int n){
	for(int i = 0; i < n;i++){
		uf[i] = i;
	}
}

int  Find(int i){
	return i == uf[i] ? uf[i]:uf[i]=Find(uf[i]);
}

void Union(int a ,int b){
	a = Find(a);
	b = Find(b);
	if(a != b){
		uf[a] = b;
	}
}

int main()
{
	int n,m,k,ans,val,val2;
	while(~scanf("%d%d",&n,&m)&&n){
		UfInit(n);
		for(int i = 0; i < m ; i++){
			scanf("%d",&k);
			if(k>0){
				scanf("%d",&val);
				for(int j = 1; j < k;j++){
					scanf("%d",&val2);
					Union(val,val2);
				}
			}
		}
		int ans = 0;
		for(int i = 0;i < n;i++)
			if(Find(i) == uf[0])
				ans++;
		printf("%d\n",ans);
	}	
	
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值