两种方法求解 Reversing Linked List

问题描述:来自陈越


作者
CHEN, Yue

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K = 3, then you must output 3→2→1→6→5→4; if K = 4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (<= 10  5 ) which is the total number of nodes, and a positive K (<=N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1. 

Then N lines follow, each describes a node in the format:

Address Data Next

where  Address is the position of the node,   Data is an integer, and   Next is the position of the next node. 

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1
求解:

法一:链表的方法:

#include <iostream>
#include <iomanip>
using namespace std;


typedef struct node
{
int Data;
int address;
int address_next;
struct node* next;
}Node;
Node *p;


int main()
{
int str,num,k;
int Adr[100001],NextAdr[100001],data[100001];
Node *p,*head,*tmp,*tmp1;
head=(Node*)malloc(sizeof(node)); //使用结点,链表务必记住要申请一个结点空间才行
tmp=(Node*)malloc(sizeof(node)); //使用结点,链表务必记住要申请一个结点空间才行

cin>>str>>num>>k;
tmp=head->next; // p is a empty head node
tmp->address=str;

///以下将输入的数据,地址转换为了一个链表/////////////////
for(int i=0;i<num;i++)
{
cin>>Adr[i]>>data[i]>>NextAdr[i];
}
for(int i=0;i<num;i++)
{
// cout<<data[i]<<" ";
if(Adr[i]==tmp->address)
{
tmp->Data=data[i];
tmp->address_next=NextAdr[i];
}
}


while(tmp->address_next!=-1)
{
for(int i=0;i<num;i++)
{
// cout<<data[i]<<" ";
if(Adr[i]==tmp->address_next)
{
tmp1=(Node*)malloc(sizeof(node));
tmp1->address=Adr[i];
tmp1->Data=data[i];
tmp1->address_next=NextAdr[i];
tmp->next=tmp1;
tmp=tmp->next;
}
}
}


// while(head)
// {
// cout<<head->Data<<" ";
// head=head->next;
// }
///以上将输入的数据,地址转换为了一个链表/////////////////
Node *new1,*old,*tmp2,*tmp3;   //链表反转
int n(1);
tmp3=head;
new1=head->next;
old=new1->next;
// tmp2=old->next;
while(n<k)
{
tmp2=old->next;
old->next=new1;
new1=old;
old=tmp2;
tmp2=tmp2->next;
n++;
}
head->next->next=old;
head->next=new1;


head=head->next;
while(head)
{
// cout<<setfill(‘0‘)<<setw(5)<<255<<endl
cout<<setfill('0')<<setw(5)<<head->address<<" "<<head->Data<<" "<<setfill('0')<<setw(5)<<head->address_next<<" "<<endl;
head=head->next;
}
return 0;
}

法二:采用数组,函数

#include <iostream>
#include <algorithm>
using namespace std;


int main()
{
int list[100010];
// int address[100010];
int node[100010][2];
int num,str,k;
int address,data,next;
cin>>str>>num>>k;
for (int i = 0; i < num; ++i)
{
cin>>address>>data>>next;
node[address][0]=data;
node[address][1]=next;
// list[i]=address;
}
int m(0),n=str;

while(n!=-1)
{
list[m]=n;
m=m+1;
n=node[n][1];
}

for(int j=0;j<num;j++)
cout<<list[j]<<endl;
int j=0;
while(j+k<num)
{
reverse(list+j,list+j+k);
j=j+k;
}


for(int i=0;i<num;i++)
{
cout<<list[i]<<" "<<node[list[i]][0]<<" "<<node[list[i]][1]<<endl;


}
}



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园整体解决方案是响应国家教育信息化政策,结合教育改革和技术创新的产物。该方案以物联网、大数据、人工智能和移动互联技术为基础,旨在打造一个安全、高效、互动且环保的教育环境。方案强调从数字化校园向智慧校园的转变,通过自动数据采集、智能分析和按需服务,实现校园业务的智能化管理。 方案的总体设计原则包括应用至上、分层设计和互联互通,确保系统能够满足不同用户角色的需求,并实现数据和资源的整合与共享。框架设计涵盖了校园安全、管理、教学、环境等多个方面,构建了一个全面的校园应用生态系统。这包括智慧安全系统、校园身份识别、智能排课及选课系统、智慧学习系统、精品录播教室方案等,以支持个性化学习和教学评估。 建设内容突出了智慧安全和智慧管理的重要性。智慧安全管理通过分布式录播系统和紧急预案一键启动功能,增强校园安全预警和事件响应能力。智慧管理系统则利用物联网技术,实现人员和设备的智能管理,提高校园运营效率。 智慧教学部分,方案提供了智慧学习系统和精品录播教室方案,支持专业级学习硬件和智能化网络管理,促进个性化学习和教学资源的高效利用。同时,教学质量评估中心和资源应用平台的建设,旨在提升教学评估的科学性和教育资源的共享性。 智慧环境建设则侧重于基于物联网的设备管理,通过智慧教室管理系统实现教室环境的智能控制和能效管理,打造绿色、节能的校园环境。电子班牌和校园信息发布系统的建设,将作为智慧校园的核心和入口,提供教务、一卡通、图书馆等系统的集成信息。 总体而言,智慧校园整体解决方案通过集成先进技术,不仅提升了校园的信息化水平,而且优化了教学和管理流程,为学生、教师和家长提供了更加便捷、个性化的教育体验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值