计算机学院大学生程序设计竞赛(2015’12)The collector’s puzzle

The collector’s puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 944    Accepted Submission(s): 210


Problem Description
There is a collector who own many valuable jewels. He has a problem about how to store them. There are M special boxes. Each box has a value. And each of the N jewels has a value too. 
The collector wants to store every jewel in one of the boxs while minimizing the sum of difference value. 
The difference value between a jewel and a box is: |a[i] - b[j]|, a[i] indicates the value of i-th jewel, b[j] indicates the value of j-th box.
Note that a box can store more than one jewel.

Now the collector turns to you for helping him to compute the minimal sum of differences.
 

Input
There are multiple test cases.
For each case, the first line has two integers N, M (1<=N, M<=100000).
The second line has N integers, indicating the N jewels’ values.
The third line have M integers, indicating the M boxes’ values.
Each value is no more than 10000.
 

Output
Print one integer, indicating the minimal sum of differences.
 

Sample Input
  
  
4 4 1 2 3 4 4 3 2 1 4 4 1 2 3 4 1 1 1 1
 

Sample Output
  
  
0 6
 

总是望着曾经的空间发呆,那些说好不分开的朋友不在了,转身,陌路。 熟悉的,安静了, 安静的,离开了, 离开的,陌生了, 陌生的,消失了, 消失的,陌路了。 快哭了

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int a[10005],b[10005];
int main()
{
    int N,M,t;
    while(~scanf("%d%d",&N,&M))
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        for(int i=0; i<N; ++i)
        {
            scanf("%d",&t);
            ++a[t];
        }
        for(int i=0; i<M; ++i)
        {
            scanf("%d",&t);
            ++b[t];
        }
        long long tol=0;
        for(int i=0; i<10005; ++i)
            if(a[i]>0)
            {
                int j;
                for(j=0;; ++j)
                {
                    if(i-j>0&&b[i-j]>0)break;
                    if(i+j<10005&&b[i+j]>0)break;
                }
                tol=tol+a[i]*j;
            }
        printf("%lld\n",tol);
    }
    return 0;
}


@执念  "@☆但求“❤”安★ 下次我们做的一定会更好。。。。吐舌头

为什么这次的题目是英文的。。。。QAQ... 哭

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值