Codeforces 847 B. Preparing for Merge Sort (二分)

Description

Ivan has an array consisting of n different integers. He decided to reorder all elements in increasing order. Ivan loves merge sort so he decided to represent his array with one or several increasing sequences which he then plans to merge into one sorted array.

Ivan represent his array with increasing sequences with help of the following algorithm.

While there is at least one unused number in array Ivan repeats the following procedure:

iterate through array from the left to the right;

Ivan only looks at unused numbers on current iteration;

if current number is the first unused number on this iteration or this number is greater than previous unused number on current iteration, then Ivan marks the number as used and writes it down.

For example, if Ivan’s array looks like [1, 3, 2, 5, 4] then he will perform two iterations. On first iteration Ivan will use and write numbers [1, 3, 5], and on second one — [2, 4].

Write a program which helps Ivan and finds representation of the given array with one or several increasing sequences in accordance with algorithm described above.

 

Input

The first line contains a single integer n (1 ≤ n ≤ 2·10^5) — the number of elements in Ivan’s array.

The second line contains a sequence consisting of distinct integers a1, a2, …, an (1 ≤ ai ≤ 10^9) — Ivan’s array.

 

Output

Print representation of the given array in the form of one or more increasing sequences in accordance with the algorithm described above. Each sequence must be printed on a new line.

 

Examples input

5
1 3 2 5 4

 

Examples output

1 3 5
2 4

 

题意

找出所有不重叠不下降的子序列。

 

思路

有一种暴力的想法:我们可以在 O(n) 的时间复杂度找出当前数组中的一个不下降子序列,然后从数组中删掉这部分继续重复刚才的操作。

不过这佯的方法时间复杂度为 O(n2) ,显然会超时。


考虑用队列来存储所有不重叠不下降的子序列,对于已拓展出的 len 个队列,显然其尾部数字的大小是按降序排列的。

比如我们有 5,4,3,2,1,6,8,7,5 这些数字,其在队列中的存储如下:

5,6,8
4,7
3,5
2
1

此时由所有队列尾部组成的序列为 8,7,5,2,1 ,对于即将加入的新数字 x ,如果在已有队列尾部可以找到一个编号最小且尾部小于等于 x 的索引,那么我们可以将 x 加入到该队列尾部,否则用它来拓展一个新队列。

查找采用二分总时间复杂度为 O(n×logn)

 

AC 代码

#include<bits/stdc++.h>
using namespace std;
const int maxn = 2e5+10;
typedef __int64 LL;

LL a[maxn];
int n;
deque<LL> top[maxn];

int lower_update(int len,LL x)      // 找一个编号最小且队列末尾元素小于 x 的索引
{
    int low = 0,high = len;
    while(low<high)
    {
        int mid = (low+high)>>1;
        if(*top[mid].rbegin()<=x)
            high = mid;
        else
            low = mid + 1;
    }
    if(high == len)return -1;
    return high;
}

void solve()
{
    int len = 0;
    for(int i=0; i<n; i++)
    {
        int res = lower_update(len,a[i]);   // 二分查找
        if(res == -1)                       // 没找到说明当前元素的值偏小
            top[len++].push_back(a[i]);
        else
            top[res].push_back(a[i]);
    }
    for(int i=0; i<len; i++)
    {
        cout<<top[i].front();
        top[i].pop_front();
        while(!top[i].empty())
        {
            cout<<" "<<top[i].front();
            top[i].pop_front();
        }
        cout<<endl;
    }
}

int main()
{
    cin>>n;
    for(int i=0; i<n; i++)
        cin>>a[i];
    solve();
    return 0;
}
"educational codeforces round 103 (rated for div. 2)"是一个Codeforces平台上的教育性比赛,专为2级选手设计评级。以下是有关该比赛的回答。 "educational codeforces round 103 (rated for div. 2)"是一场Codeforces平台上的教育性比赛。Codeforces是一个为程序员提供竞赛和评级的在线平台。这场比赛是专为2级选手设计的,这意味着它适合那些在算法和数据结构方面已经积累了一定经验的选手参与。 与其他Codeforces比赛一样,这场比赛将由多个问题组成,选手需要根据给定的问题描述和测试用例,编写程序来解决这些问题。比赛的时限通常有两到三个小时,选手需要在规定的时间内提交他们的解答。他们的程序将在Codeforces的在线评测系统上运行,并根据程序的正确性和效率进行评分。 该比赛被称为"educational",意味着比赛的目的是教育性的,而不是针对专业的竞争性。这种教育性比赛为选手提供了一个学习和提高他们编程技能的机会。即使选手没有在比赛中获得很高的排名,他们也可以从其他选手的解决方案中学习,并通过参与讨论获得更多的知识。 参加"educational codeforces round 103 (rated for div. 2)"对于2级选手来说是很有意义的。他们可以通过解决难度适中的问题来测试和巩固他们的算法和编程技巧。另外,这种比赛对于提高解决问题能力,锻炼思维和提高团队合作能力也是非常有帮助的。 总的来说,"educational codeforces round 103 (rated for div. 2)"是一场为2级选手设计的教育性比赛,旨在提高他们的编程技能和算法能力。参与这样的比赛可以为选手提供学习和进步的机会,同时也促进了编程社区的交流与合作。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值